﻿<!doctype html><html lang="fr-FR"><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><script data-cfasync="false" id="ao_optimized_gfonts_config" type="text/javascript">WebFontConfig={google:{families:["Lora:400,400i,700,700i","Source Sans Pro:400,600,700","Playfair Display:400,400i","PT Sans:400,700"] },classes:false, events:false, timeout:1500};</script><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href=""><link type="text/css" media="all" href="https://www.jesuisundev.com/wp-content/cache/autoptimize/css/autoptimize_f7fa06a74715dfa07f4a732d290bc05f.css" rel="stylesheet" /><title>Pourquoi les développeur(euse)s détestent PHP - Je suis un dev</title><meta name="description" content="Le PHP est le langage le plus utilisé au monde. C’est aussi le plus détesté. Et c’est de la haine pure. Mais pourquoi tant de haine?"/><link rel="canonical" href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/" /><meta property="og:locale" content="fr_FR" /><meta property="og:type" content="article" /><meta property="og:title" content="Pourquoi les développeur(euse)s détestent PHP" /><meta property="og:description" content="Le PHP est le langage le plus utilisé au monde. C’est aussi le plus détesté. Et c’est de la haine pure. Mais pourquoi tant de haine?" /><meta property="og:url" content="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/" /><meta property="og:site_name" content="Je suis un dev" /><meta property="article:tag" content="développement" /><meta property="article:tag" content="développeur" /><meta property="article:tag" content="développeuse" /><meta property="article:tag" content="php" /><meta property="article:section" content="développement" /><meta property="article:published_time" content="2019-09-23T04:05:19+00:00" /><meta property="article:modified_time" content="2019-09-23T14:54:31+00:00" /><meta property="og:updated_time" content="2019-09-23T14:54:31+00:00" /><meta property="og:image" content="https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg" /><meta property="og:image:secure_url" content="https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="500" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Le PHP est le langage le plus utilisé au monde. C’est aussi le plus détesté. Et c’est de la haine pure. Mais pourquoi tant de haine?" /><meta name="twitter:title" content="Pourquoi les développeur(euse)s détestent PHP" /><meta name="twitter:image" content="https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg" /><meta name="twitter:creator" content="@jesuisundev" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.jesuisundev.com/#website","url":"https://www.jesuisundev.com/","name":"Je suis un dev","potentialAction":{"@type":"SearchAction","target":"https://www.jesuisundev.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#primaryimage","url":"https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg","width":750,"height":500},{"@type":"WebPage","@id":"https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#webpage","url":"https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/","inLanguage":"fr-FR","name":"Pourquoi les d\u00e9veloppeur(euse)s d\u00e9testent PHP - Je suis un dev","isPartOf":{"@id":"https://www.jesuisundev.com/#website"},"primaryImageOfPage":{"@id":"https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#primaryimage"},"datePublished":"2019-09-23T04:05:19+00:00","dateModified":"2019-09-23T14:54:31+00:00","author":{"@id":"https://www.jesuisundev.com/#/schema/person/d07b4e39118f22f8c6651208393950f4"},"description":"Le PHP est le langage le plus utilis\u00e9 au monde. C\u2019est aussi le plus d\u00e9test\u00e9. Et c\u2019est de la haine pure. Mais pourquoi tant de haine?"},{"@type":["Person"],"@id":"https://www.jesuisundev.com/#/schema/person/d07b4e39118f22f8c6651208393950f4","name":"jesuisundev","image":{"@type":"ImageObject","@id":"https://www.jesuisundev.com/#authorlogo","url":"https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=96&d=mm&r=g","caption":"jesuisundev"},"description":"a","sameAs":["https://twitter.com/jesuisundev"]}]}</script> <link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' /><link href='https://ajax.googleapis.com' rel='preconnect' /><link href='https://fonts.googleapis.com' rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="Je suis un dev &raquo; Flux" href="https://www.jesuisundev.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Je suis un dev &raquo; Flux des commentaires" href="https://www.jesuisundev.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Je suis un dev &raquo; Pourquoi les développeur(euse)s détestent PHP Flux des commentaires" href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/feed/" /> <script type='text/javascript' src='https://www.jesuisundev.com/wp-includes/js/jquery/jquery.js'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.jesuisundev.com/wp-content/themes/nimbo/js/html5shiv.min.js'></script> <![endif]--> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.jesuisundev.com/wp-content/themes/nimbo/js/respond.min.js'></script> <![endif]--><link rel='https://api.w.org/' href='https://www.jesuisundev.com/wp-json/' /><meta name="generator" content="WordPress 5.2.3" /><link rel='shortlink' href='https://www.jesuisundev.com/?p=3531' /><link rel="alternate" type="application/json+oembed" href="https://www.jesuisundev.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.jesuisundev.com%2Fpourquoi-les-developpeurs-detestent-php%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.jesuisundev.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.jesuisundev.com%2Fpourquoi-les-developpeurs-detestent-php%2F&#038;format=xml" /><link rel="icon" href="https://www.jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" sizes="32x32" /><link rel="icon" href="https://www.jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://www.jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" /><meta name="msapplication-TileImage" content="https://www.jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" /> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-55526551-1"></script><script>window.dataLayer = window.dataLayer || [];  function gtag(){dataLayer.push(arguments);}  gtag('js', new Date());  gtag('config', 'UA-55526551-1');</script> <script data-cfasync="false" id="ao_optimized_gfonts_webfontloader" type="text/javascript">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head><body data-rsssl=1 class="post-template-default single single-post postid-3531 single-format-standard wp-custom-logo wp-embed-responsive"><header id="bwp-header" class="bwp-header-two-rows"><div class="bwp-header-logo-row"><div class="container"><div class="bwp-header-logo-row-container clearfix"><div id="bwp-custom-logo" class="bwp-logo-container bwp-logo-image-container"
 data-logo-url="https://www.jesuisundev.com/wp-content/uploads/2019/07/cropped-cropped-jesuisundev_logo_black.png"
 data-dark-logo-url="https://www.jesuisundev.com/wp-content/uploads/2019/07/cropped-jesuisundev_logo_white-1.png"
 data-logo-alt="Je suis un dev"> <a href="https://www.jesuisundev.com/" class="custom-logo-link" rel="home"><img width="200" height="113" src="https://www.jesuisundev.com/wp-content/uploads/2019/07/cropped-cropped-jesuisundev_logo_black.png" class="custom-logo" alt="Je suis un dev" /></a></div> <br><br> <span>Je te donne plein de conseils utiles pour faire du dev. Y'a des gifs marrants aussi.</span> <br><br> <a style="padding: 10px 8px;" href="https://twitter.com/jesuisundev" target="_blank" rel="noopener"> <i class="fab fa-twitter"></i> </a> <a style="padding: 10px 8px;" href="mailto:admin@jesuisundev.com" rel="noopener"> <i class="far fa-envelope"></i> </a> <a style="padding: 10px 8px;" href="https://www.jesuisundev.com/feed/" target="_blank" rel="noopener"> <i class="fas fa-rss-square"></i> </a></div></div></div><div class="bwp-header-nav-row"><div class="container"><div class="bwp-header-nav-row-container clearfix"> <a href="#" rel="nofollow" id="bwp-color-switch" class="bwp-color-switch-icon"> <i class="far fa-moon"></i> </a></div></div></div></header><section id="bwp-single-post"><div class="container"><div class="bwp-single-post-container bwp-full-width-layout" role="main"><article id="bwp-post-3531" class="post-3531 post type-post status-publish format-standard has-post-thumbnail hentry category-developpement category-developpeur category-developpeuse category-php-2 tag-developpement tag-developpeur tag-developpeuse tag-php bwp-single-post-article"><figure class="bwp-post-media"> <noscript><img width="750" height="500" src="https://www.jesuisundev.com/wp-content/uploads/2019/08/php-750x500.jpg" class="attachment-nimbo-1200x500-crop size-nimbo-1200x500-crop wp-post-image" alt="" srcset="https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg 750w, https://www.jesuisundev.com/wp-content/uploads/2019/08/php-300x200.jpg 300w" sizes="(max-width: 750px) 100vw, 750px" /></noscript><img width="750" height="500" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20750%20500%22%3E%3C/svg%3E' data-src="https://www.jesuisundev.com/wp-content/uploads/2019/08/php-750x500.jpg" class="lazyload attachment-nimbo-1200x500-crop size-nimbo-1200x500-crop wp-post-image" alt="" data-srcset="https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg 750w, https://www.jesuisundev.com/wp-content/uploads/2019/08/php-300x200.jpg 300w" data-sizes="(max-width: 750px) 100vw, 750px" /></figure><div class="bwp-post-content"><ul class="bwp-single-post-metadata list-unstyled"><li class="bwp-single-post-meta-date"> <span>Posted on</span> <a href="https://www.jesuisundev.com/2019/09/23/"> <span class="date updated">23 septembre 2019</span> </a></li><li class="bwp-single-post-meta-author"> <span>By</span> <a href="https://www.jesuisundev.com/author/vooodoo/" title="Posts by jesuisundev" rel="author"> <span class="vcard author"> <span class="fn">jesuisundev</span> </span> </a></li><li class="bwp-single-post-meta-categories"> <span>In</span> <a href="https://www.jesuisundev.com/category/developpement/" rel="category tag">développement</a>, <a href="https://www.jesuisundev.com/category/developpeur/" rel="category tag">développeur</a>, <a href="https://www.jesuisundev.com/category/developpeuse/" rel="category tag">développeuse</a>, <a href="https://www.jesuisundev.com/category/php-2/" rel="category tag">PHP</a></li></ul><h1 class="bwp-post-title entry-title">Pourquoi les développeur(euse)s détestent PHP</h1><div class="bwp-content entry-content clearfix"><p>Le PHP est le langage le plus utilisé au monde. C’est aussi le plus détesté. Et c’est de la haine pure. Mais pourquoi autant de développeur(euse)s le détestent autant ? Aujourd’hui on va aller jusqu’à l&#8217;origine de la haine et on va voir si elle est vraiment fondée.</p> <br><br><h3>Touche pas à mon PHP</h3><p>Si j&#8217;ai l&#8217;aplomb de t&#8217;affirmer que PHP est détesté par le monde entier c&#8217;est pas un avis personnel. Je te sors pas ça pour troller. Je sais que c&#8217;est mon genre mais là c&#8217;est pas le cas. Dans la dernière enquête de stack overflow les développeur(euse)s du monde entier ont mis PHP <a rel="noreferrer noopener" aria-label="dans le top 5  (s’ouvre dans un nouvel onglet)" href="https://insights.stackoverflow.com/survey/2019#most-loved-dreaded-and-wanted" target="_blank">dans le top 5 </a>des langages les plus craints. La dernière enquête de chez Hired le met carrément <a rel="noreferrer noopener" aria-label="en premiere place (s’ouvre dans un nouvel onglet)" href="https://hired.com/page/state-of-software-engineers/hottest-coding-languages/" target="_blank">en première place</a> des plus détestés. Y&#8217;en a plein d&#8217;autres c&#8217;est accablant et je te parle même pas de ce qui se passe sur <a rel="noreferrer noopener" aria-label="Reedit (s’ouvre dans un nouvel onglet)" href="https://www.reddit.com/r/lolphp/" target="_blank">Reddit</a>. Si t’es un(e) développeur(euse) PHP depuis 20 ans venu(e) ici en croisade pour me crucifier sur l&#8217;autel de Symfony détends toi deux minutes s&#8217;il te plait. On est là pour discuter, pose cette arme. Bon maintenant au contraire si tu hais PHP avec passion : prends des pop-corns et assieds toi confort&#8217; t’es au bon endroit.</p> <br><br><figure class="wp-block-image size-full aligncenter"><noscript><img src="https://www.jesuisundev.com/wp-content/uploads/2019/08/popcorn.gif" alt="" class="wp-image-3864"/></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.jesuisundev.com/wp-content/uploads/2019/08/popcorn.gif" alt="" class="lazyload wp-image-3864"/></figure> <br><br><p>Bon t&#8217;es au bon endroit c&#8217;est pas sûr en fait. Il y a quelques années je faisais moi-même du Symfony2. Et j&#8217;ai fait ça pendant des années. Et j&#8217;aimais bien cette affaire de Symfony franchement c&#8217;est pas mal. Y&#8217;a très peu de temps j&#8217;ai raconté ça à un développeur que j&#8217;ai rencontré à un meetup devops. Il était choqué, à deux doigt de vomir, il me regardait comme si j&#8217;avais assassiné un nouveau-né. À partir de maintenant je vais l’appeler Jean-Jean pour que ça soit plus simple. Du coup j&#8217;ai tout de suite posé une question à Jean-Jean : pourquoi tant de haine ?</p> <br><br><h3>Le passé de PHP</h3><p>Pour comprendre ce qui va suivre il te faut du contexte. Pour ce faire petit retour en arrière. Nous somme en 1994 et <a rel="noreferrer noopener" aria-label="Rasmus Lerdorf  (s’ouvre dans un nouvel onglet)" href="https://twitter.com/rasmus" target="_blank">Rasmus Lerdorf </a>code rapidement une suite d&#8217;outils en C. Cette suite d&#8217;outils lui sert à gérer son site web perso. Rasmus il fait ça juste pour sa gueule à ce moment là. Il ne veut pas en faire un langage de programmation. Rien n&#8217;est désigné dans cette suite d&#8217;outils pour le devenir. Un an plus tard Rasmus publie en open source cette suite d&#8217;outils appelée alors : PHP/FI. Et ça ressemblait à ça.</p> <br><br><pre class="EnlighterJSRAW" data-enlighter-language="php" data-enlighter-theme="" data-enlighter-highlight="" data-enlighter-linenumbers="" data-enlighter-lineoffset="" data-enlighter-title="" data-enlighter-group="">&lt;!--include /text/header.html-->

&lt;!--getenv HTTP_USER_AGENT-->
&lt;!--ifsubstr $exec_result Mozilla-->
  Hey, you are using Netscape!&lt;p>
&lt;!--endif-->

&lt;!--sql database select * from table where user='$username'-->
&lt;!--ifless $numentries 1-->
  Sorry, that record does not exist&lt;p>
&lt;!--endif exit-->
  Welcome &lt;!--$user-->!&lt;p>
  You have &lt;!--$index:0--> credits left in your account.&lt;p>

&lt;!--include /text/footer.html--></pre><br><br><p>On est loin de ce que tu utilises aujourd’hui dans ton énorme framework PHP7 pas vrai ? Pourtant tout vient de là. Pour la suite de l&#8217;histoire le code est repris par une équipe de dev et PHP/FI2 sort en 1997. En 1998 une partie est réécrite et PHP3 fait son apparition. En 1999 le cœur de PHP est totalement réécrit pour produire <a rel="noreferrer noopener" aria-label="Zend (s’ouvre dans un nouvel onglet)" href="https://en.wikipedia.org/wiki/Zend_Engine" target="_blank">Zend</a>. PHP4 suit l&#8217;année d’après et PHP5 sort en 2004 avec Zend2. PHP6 est carrément annulé tellement son développement s&#8217;est transformé en enfer sur terre. Enfin via une énième réécriture majeur du langage : PHP7 sort en 2015. Je me rappelle qu&#8217;a l&#8217;époque <a rel="noreferrer noopener" aria-label="j'était tout exciter (s’ouvre dans un nouvel onglet)" href="https://www.jesuisundev.com/ce-que-vous-devez-savoir-sur-php7-concretement/" target="_blank">j&#8217;étais tout excité</a>. Mais à la base Rasmus il codait juste son truc dans son coin. En 2003 il fait <a rel="noreferrer noopener" aria-label="une interview (s’ouvre dans un nouvel onglet)" href="https://web.archive.org/web/20130728125152/http://itc.conversationsnetwork.org/shows/detail58.html" target="_blank">une interview</a> et raconte des choses incroyables.<br><br><em>&#8220;Je n&#8217;aime vraiment pas la programmation. J&#8217;ai construit cet outil pour programmer moins afin de pouvoir simplement réutiliser du code[…].</em> <em>Je ne sais pas comment l&#8217;arrêter, il n&#8217;y a jamais eu d&#8217;intention d&#8217;écrire un langage de programmation […]. Je ne sais absolument pas comment écrire un langage de programmation, j&#8217;ai juste continué à ajouter l&#8217;étape logique suivante.&#8221;</em></p> <br><br><figure class="wp-block-image size-full aligncenter"><noscript><img src="https://i.imgur.com/Hlc8dlM.gif" alt=""/></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://i.imgur.com/Hlc8dlM.gif" alt=""/></figure> <br><br><h3>Inconsistance et mauvais design</h3><p>Retour en 2019 avec notre ami Jean-Jean du meetup qui vomit PHP comme pas possible. Il a tout de suite commencé à me parler de la syntaxe &#8220;dégueulasse&#8221; de PHP. Du fait que le langage soit non typé. Du fait que cette &#8220;horreur de langage&#8221; soit la plupart du temps imprévisible. Que ça soit du côté des retours de fonction ou bien de l&#8217;utilisation des opérateurs. Il y a également les inconsistances incroyables du nommage des fonctions. Bref je t&#8217;épargne la liste des problèmes techniques car sinon cet article va te prendre la journée à lire.</p><p>Si vraiment tu veux tout savoir je t&#8217;ai trouvé la personne la plus énervée du monde contre PHP qui <a rel="noreferrer noopener" aria-label="déverse sa haine (s’ouvre dans un nouvel onglet)" href="https://eev.ee/blog/2012/04/09/php-a-fractal-of-bad-design/" target="_blank">déverse sa haine</a> sans retenu. Non, en fait je crois que celui qui déteste le plus PHP <a rel="noreferrer noopener" aria-label=" (s’ouvre dans un nouvel onglet)" href="https://whydoesitsuck.com/why-does-php-suck/" target="_blank">c&#8217;est lui</a> en fait. Des articles comme ça y&#8217;en a 1 milliards sur les internets. Et ils valident tous pas mal ce que me disait Jean-Jean. <strong>Les développeur(euse)s détestent PHP car c&#8217;est un langage techniquement inconsistant avec un mauvais design.</strong> Quand on le compare à d&#8217;autres langages le contraste est flagrant. Si après la lecture de ces deux articles tu ne peux pas avouer que PHP a des problèmes alors c&#8217;est que c&#8217;est devenu ta religion. Et j&#8217;ai arrêté d&#8217;essayer de convaincre des fanatiques.</p> <br><br><figure class="wp-block-image size-full aligncenter"><noscript><img src="https://www.jesuisundev.com/wp-content/uploads/2019/08/php_best_practices.jpg" alt="php" class="wp-image-3659" srcset="https://www.jesuisundev.com/wp-content/uploads/2019/08/php_best_practices.jpg 520w, https://www.jesuisundev.com/wp-content/uploads/2019/08/php_best_practices-240x300.jpg 240w" sizes="(max-width: 520px) 100vw, 520px" /></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.jesuisundev.com/wp-content/uploads/2019/08/php_best_practices.jpg" alt="php" class="lazyload wp-image-3659" data-srcset="https://www.jesuisundev.com/wp-content/uploads/2019/08/php_best_practices.jpg 520w, https://www.jesuisundev.com/wp-content/uploads/2019/08/php_best_practices-240x300.jpg 240w" data-sizes="(max-width: 520px) 100vw, 520px" /></figure> <br><br><p>En PHP c&#8217;est très facile de <a rel="noreferrer noopener" aria-label="coder quelque chose avec son cul (s’ouvre dans un nouvel onglet)" href="https://www.jesuisundev.com/pourquoi-les-developpeureuses-codent-avec-le-cul/" target="_blank">coder quelque chose avec son cul</a>. D&#8217;autres languages ont beaucoup plus de restrictions et empêchent les libertés et les facilités. Le meilleur  exemple ici est le fort typage présent dans beaucoup de langage. On voit aussi beaucoup de problèmes de sécurité avec PHP. Et le problème est le même : c&#8217;est très facile de faire du code non sécurisé avec PHP. Mais PHP n&#8217;est pas un trou de sécurité si on fait les choses proprement. <strong>Les développeur(euse)s détestent PHP car tu es plus susceptible d&#8217;avoir des erreurs avec un langage qui laisse autant de liberté.</strong> Et les bugs dans du spaghetti code PHP c&#8217;est pas la joie. Surtout quand grand nombre de ces utilisateurs sont des débutants du fait de la facilité d’accès de PHP.</p> <br><br><h3>Victime de son succès</h3><p>Il y a un autre facteur important dans cette haine ambiante. <strong>Les développeur(euse)s détestent PHP car il est utilisé partout</strong>. Ce blog tourne sur du PHP7. Comme la majeure partie du web j&#8217;ai juste besoin d&#8217;hoster une page dynamique qui est ensuite cachée en HTML statique. Mon blog c&#8217;est pas Amazon. Et du coup <strong>PHP ça fait la job</strong> comme au dit au Québec. Oui le langage en lui même n&#8217;est pas le meilleur. Oui il y a plus joli. Mais on s&#8217;en fout en fait. Ca répond à mon besoin de façon rapide et accessible. Et c&#8217;est également pour cette raison que <a rel="noreferrer noopener" href="https://w3techs.com/technologies/details/pl-php/all/all" target="_blank">80% du web</a> tourne en PHP.</p><p>Quand j&#8217;ai expliqué la même chose à Jean-Jean il a commencé à bouillonner. Comme toi et moi Jean-Jean a des amis et de la famille. Ces gens lui demandent fréquemment de l&#8217;aide pour leur site pro et perso. <strong>Devine quelle langage revient toujours sur les sites de ces connaissances ?</strong> Du coup Jean-Jean il se retrouve de temps à autre à devoir changer des choses en PHP. Et ça, ça lui file un mal de tête incroyable.</p><figure class="wp-block-image size-full aligncenter"><noscript><img src="https://www.jesuisundev.com/wp-content/uploads/2019/08/stress-php.jpg" alt="php" class="wp-image-3661" srcset="https://www.jesuisundev.com/wp-content/uploads/2019/08/stress-php.jpg 700w, https://www.jesuisundev.com/wp-content/uploads/2019/08/stress-php-244x300.jpg 244w" sizes="(max-width: 700px) 100vw, 700px" /></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.jesuisundev.com/wp-content/uploads/2019/08/stress-php.jpg" alt="php" class="lazyload wp-image-3661" data-srcset="https://www.jesuisundev.com/wp-content/uploads/2019/08/stress-php.jpg 700w, https://www.jesuisundev.com/wp-content/uploads/2019/08/stress-php-244x300.jpg 244w" data-sizes="(max-width: 700px) 100vw, 700px" /></figure> <br><br><p>Avec l’avènement de WordPress qui domine littéralement les Internets Jean-Jean a pas fini de rager. En passant je te parle comme si ce langage savait que chier un blog comme le mien, mais pas du tout ! Facebook, Wikipedia, Yahoo, Flickr, Tumblr tous ces sites tournent en PHP et accueillent des millions d&#8217;utilisateurs tous les mois et des milliers de façons concurrentes sans broncher. PHP fait ça très bien et il le fait depuis longtemps.</p> <br><br><h2>Vieux de la veille</h2><p>Ca fait 10 ans que t&#8217;entends que PHP va mourir. Pourtant il est toujours là. Malgré le temps et les dernières technologies hypes il ne bouge pas. <strong>Les développeur(euse)s détestent PHP car c&#8217;est le contraire du </strong><a rel="noreferrer noopener" aria-label="hype driven development (s’ouvre dans un nouvel onglet)" href="https://www.cygnismedia.com/blog/hype-driven-development/" target="_blank"><strong>hype driven development</strong></a><strong>.</strong> Dans un métier ou tout le monde investit rapidement sur les dernières nouveautés, PHP est un vieux monsieur qui ne veut pas vendre son terrain. Un vieux monsieur qui continue à danser de façon insolente avec ces 80% d&#8217;occupation du web.</p> <br><br><figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">The reports of my death are greatly exaggerated. <a href="https://t.co/dFTe63T4pG">pic.twitter.com/dFTe63T4pG</a></p>&mdash; php.net (@official_php) <a href="https://twitter.com/official_php/status/1161431862931349504?ref_src=twsrc%5Etfw">August 14, 2019</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure> <br><br><p>Bref en tout cas ma discussion avec Jean-Jean continue normalement et tout d&#8217;un coup il me dit quelque chose de complètement choquant tellement c&#8217;est faux. <em>&#8220;En plus de ça PHP est de très loin le langage le plus lent de tout ce que tu trouve pour faire du web&#8221;.</em> Quand il a dit ça j&#8217;ai compris que Jean-Jean avait pas <a rel="noreferrer noopener" aria-label="fait sa veille (s’ouvre dans un nouvel onglet)" href="https://www.jesuisundev.com/veille-technologique-rester-a-jour-sans-devenir-tare/" target="_blank">fait sa veille</a> depuis longtemps.</p> <br><br><h3>PHP évolue, pas sa réputation</h3><p>Dans la tête de beaucoup de développeur(euse)s, PHP est resté en version 4. À l&#8217;époque ou le langage était instable, où la performance était désastreuse et où la POO était inexistante. <strong>Les développeur(euse)s détestent PHP car ils sont persuadés que le langage stagne depuis 20 ans</strong>. Quand tu connais PHP aujourd&#8217;hui et tous les frameworks qu&#8217;ils l&#8217;entourent force est de constater qu&#8217;on est loin de PHP4.</p><p><a rel="noreferrer noopener" aria-label="PHP7 est plus rapide (s’ouvre dans un nouvel onglet)" href="https://benchmarksgame-team.pages.debian.net/benchmarksgame/fastest/php.html" target="_blank">PHP7 est plus rapide</a> que Python et Ruby. Le langage peut être <a rel="noreferrer noopener" aria-label="fortement typé (s’ouvre dans un nouvel onglet)" href="https://stitcher.io/blog/typed-properties-in-php-74" target="_blank">fortement typé</a> si tu le souhaites. Le tooling évolue aussi avec des <a aria-label="PHP7.4  (s’ouvre dans un nouvel onglet)" href="https://github.com/phpstan/phpstan">analyseurs statiques</a> qui sont apparus ces dernières années. Les frameworks comme Symfony ou Zend forcent les bonnes pratiques. Une nouvelle version est release tous les ans avec un agenda bien précis. D&#8217;ailleurs <a rel="noreferrer noopener" aria-label="PHP7.4  (s’ouvre dans un nouvel onglet)" href="https://www.php.net/index.php#id2019-09-05-1" target="_blank">PHP7.4 </a>arrive bientôt et promet encore plus de <a rel="noreferrer noopener" aria-label="performance (s’ouvre dans un nouvel onglet)" href="https://www.phoronix.com/scan.php?page=news_item&amp;px=PHP-7.4-RC1-Released" target="_blank">performance</a>. Encore une fois je vais pas te faire la liste de tout ce qui se passe dans le PHP moderne par soucis de longueur. Si tu veux tout savoir je t&#8217;invite à consulter <a rel="noreferrer noopener" aria-label="cette article (s’ouvre dans un nouvel onglet)" href="https://stitcher.io/blog/php-in-2019" target="_blank">cet article</a> qui va t&#8217;ouvrir les yeux sur PHP en 2019. Il est temps de nuancer ton regard haineux qui date de 2003 sur un langage qui n&#8217;a plus rien à voir avec ce qu&#8217;il était.</p> <br><br><figure class="wp-block-image size-full aligncenter"><noscript><img src="https://www.jesuisundev.com/wp-content/uploads/2019/08/thanks.gif" alt="php7" class="wp-image-3872"/></noscript><img src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://www.jesuisundev.com/wp-content/uploads/2019/08/thanks.gif" alt="php7" class="lazyload wp-image-3872"/></figure> <br><br><p>Si je fais cet article c&#8217;est aussi pour ouvrir les yeux aux gens qui n&#8217;ont pas touché à PHP depuis longtemps et qui ont une haine aveugle envers le langage. <strong>Les développeur(euse)s détestent PHP car c&#8217;est cool de détester PHP</strong>. Ce langage continue à se trainer cette réputation de language monstre alors qu&#8217;il s&#8217;agit d&#8217;un langage comme les autres. Avec certes un fort legacy et pas mal de problème mais avec autant de forces.</p> <br><br><h3>Épilogue</h3><p>La plupart des développeur(euse)s qui détestent PHP le détestent par élitisme ou par ignorance. Dans les deux cas c&#8217;est débile. Il faut choisir une technologie par rapport à son besoin. PHP est fortement utile et performant dans de nombreux scénarios. Et le sortir de l&#8217;équation seulement à cause de sa réputation et aussi con que désespérant. Et y&#8217;a plein de gens désespérants.</p><div class="clearfix"></div></div><div class="bwp-single-post-tags"> Tags:<a href="https://www.jesuisundev.com/tag/developpement/" rel="tag">développement</a>, <a href="https://www.jesuisundev.com/tag/developpeur/" rel="tag">développeur</a>, <a href="https://www.jesuisundev.com/tag/developpeuse/" rel="tag">développeuse</a>, <a href="https://www.jesuisundev.com/tag/php/" rel="tag">php</a></div><div class="clearfix"><div class="bwp-single-post-share"> <span>Share</span><ul class="bwp-single-post-share-list list-unstyled"><li> <a href="https://twitter.com/share?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&text=Pourquoi les développeur(euse)s détestent PHP" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&text=Pourquoi les développeur(euse)s détestent PHP', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-twitter"></i> </a></li><li> <a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&t=Pourquoi%20les%20d%C3%A9veloppeur%28euse%29s%20d%C3%A9testent%20PHP" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&t=Pourquoi%20les%20d%C3%A9veloppeur%28euse%29s%20d%C3%A9testent%20PHP', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-facebook-f"></i> </a></li><li> <a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&media=https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg&description=Pourquoi%20les%20d%C3%A9veloppeur%28euse%29s%20d%C3%A9testent%20PHP" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&media=https://www.jesuisundev.com/wp-content/uploads/2019/08/php.jpg&description=Pourquoi%20les%20d%C3%A9veloppeur%28euse%29s%20d%C3%A9testent%20PHP', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-pinterest-p"></i> </a></li><li> <a href="https://vk.com/share.php?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-vk"></i> </a></li><li> <a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&title=Pourquoi%20les%20d%C3%A9veloppeur%28euse%29s%20d%C3%A9testent%20PHP" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/&title=Pourquoi%20les%20d%C3%A9veloppeur%28euse%29s%20d%C3%A9testent%20PHP', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-reddit-alien"></i> </a></li></ul></div></div><nav class="navigation post-navigation" role="navigation"><h2 class="screen-reader-text">Navigation de l’article</h2><div class="nav-links"><div class="nav-previous"><a href="https://www.jesuisundev.com/recueil-de-blogs-de-developpeurseuses/" rel="prev"><span class="meta-nav"><i class="fas fa-caret-left"></i>Previous post</span><span class="post-title-nav">Recueil de blogs de développeurs(euses)</span></a></div></div></nav></div></article><h2 class="bwp-container-title">Qui me parle ?</h2><div class="bwp-about-author clearfix bwp-no-avatars"><div class="bwp-about-author-bio-wrap"><div class="bwp-about-author-bio">Je suis un dev. 
En ce moment je suis Backend Développeur / DevOps à <a href="https://montreal.ubisoft.com/" target="_blank">Ubisoft</a>. 
Je suis passionné du dev et expert en blagues. 
Je continue à te parler quotidiennement sur mon <a href="https://www.twitter.com/jesuisundev/" target="_blank">Twitter</a>. 
Tu peux m'insulter à cette <a href="mailto:admin@jesuisundev.com">e-mail</a> ou le faire directement dans les commentaires juste en dessous.</div></div></div><div id="comments" class="comments-area"><h2 class="comments-title"> Commentaire(s)</h2><div class="comment-list-wrap"><ol class="comment-list"><li id="comment-888" class="comment even thread-even depth-1 parent"><article id="div-comment-888" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/02a9ac5c816fee4ee6e68128eb3900f7?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/02a9ac5c816fee4ee6e68128eb3900f7?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/02a9ac5c816fee4ee6e68128eb3900f7?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/02a9ac5c816fee4ee6e68128eb3900f7?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">inutile</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-888"> <time datetime="2019-09-23T07:29:20+02:00"> 23 septembre 2019 à 7 h 29 min </time> </a></div></footer><div class="comment-content"><p>&#8220;Si je fait cet article[&#8230;]&#8221;<br /> fais<br /> 😉</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-888' data-commentid="888" data-postid="3531" data-belowelement="div-comment-888" data-respondelement="respond" aria-label='Répondre à inutile'>Répondre</a></div></article><ol class="children"><li id="comment-949" class="comment byuser comment-author-vooodoo bypostauthor odd alt depth-2 parent"><article id="div-comment-949" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">jesuisundev</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-949"> <time datetime="2019-09-23T16:14:08+02:00"> 23 septembre 2019 à 16 h 14 min </time> </a></div></footer><div class="comment-content"><p>Corrigé. Merci pour la coquille !</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-949' data-commentid="949" data-postid="3531" data-belowelement="div-comment-949" data-respondelement="respond" aria-label='Répondre à jesuisundev'>Répondre</a></div></article><ol class="children"><li id="comment-956" class="comment even depth-3"><article id="div-comment-956" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/170e379e5e9868939f4854d034ba702c?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/170e379e5e9868939f4854d034ba702c?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/170e379e5e9868939f4854d034ba702c?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/170e379e5e9868939f4854d034ba702c?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Elfonko</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-956"> <time datetime="2019-09-23T19:20:27+02:00"> 23 septembre 2019 à 19 h 20 min </time> </a></div></footer><div class="comment-content"><p>&#8220;sans retenuE&#8221;</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-956' data-commentid="956" data-postid="3531" data-belowelement="div-comment-956" data-respondelement="respond" aria-label='Répondre à Elfonko'>Répondre</a></div></article></li><li id="comment-957" class="comment odd alt depth-3"><article id="div-comment-957" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/1cb3b3db7bf3c79787100a918c69d49d?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1cb3b3db7bf3c79787100a918c69d49d?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/1cb3b3db7bf3c79787100a918c69d49d?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/1cb3b3db7bf3c79787100a918c69d49d?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Diallo29</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-957"> <time datetime="2019-09-23T19:38:58+02:00"> 23 septembre 2019 à 19 h 38 min </time> </a></div></footer><div class="comment-content"><p>Bonne réaction.😌</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-957' data-commentid="957" data-postid="3531" data-belowelement="div-comment-957" data-respondelement="respond" aria-label='Répondre à Diallo29'>Répondre</a></div></article></li></ol></li></ol></li><li id="comment-891" class="comment even thread-odd thread-alt depth-1 parent"><article id="div-comment-891" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/d12a0d3c9e5c03bec07d631bb3518596?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d12a0d3c9e5c03bec07d631bb3518596?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/d12a0d3c9e5c03bec07d631bb3518596?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/d12a0d3c9e5c03bec07d631bb3518596?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Jos</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-891"> <time datetime="2019-09-23T08:06:04+02:00"> 23 septembre 2019 à 8 h 06 min </time> </a></div></footer><div class="comment-content"><p>&#8220;La plupart des développeur(euse)s qui détestent PHP le détestent par élitisme ou par ignorance&#8221;<br /> Faux, on le déteste car on sait qu&#8217;on à 9 chances sur 10 de tomber sur un projet codé avec les pieds en PHP 😀</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-891' data-commentid="891" data-postid="3531" data-belowelement="div-comment-891" data-respondelement="respond" aria-label='Répondre à Jos'>Répondre</a></div></article><ol class="children"><li id="comment-930" class="comment odd alt depth-2"><article id="div-comment-930" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/a34d1ddd72a5a36897fff89610d12af0?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a34d1ddd72a5a36897fff89610d12af0?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/a34d1ddd72a5a36897fff89610d12af0?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/a34d1ddd72a5a36897fff89610d12af0?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">poulinko</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-930"> <time datetime="2019-09-23T13:41:29+02:00"> 23 septembre 2019 à 13 h 41 min </time> </a></div></footer><div class="comment-content"><p>Oui. Mais on a aussi 9 chances sur 10 de tomber sur un projet codé avec les pieds tout court 😉</p><p>Les appli qui ont le plus de besoin de maintenance sont les applis les plus mal codés. Comme il faut 10 fois plus de temps pour réaliser une évolution sur une appli codée avec les pieds par rapport à une appli bien codée, on a 9 chances sur 10 de tomber sur des applis mal codés. cqfd 😉</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-930' data-commentid="930" data-postid="3531" data-belowelement="div-comment-930" data-respondelement="respond" aria-label='Répondre à poulinko'>Répondre</a></div></article></li><li id="comment-935" class="comment even depth-2"><article id="div-comment-935" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/d559363ea6ea7858ca0d00a81e8bed8c?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d559363ea6ea7858ca0d00a81e8bed8c?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/d559363ea6ea7858ca0d00a81e8bed8c?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/d559363ea6ea7858ca0d00a81e8bed8c?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Mmmmmh ok</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-935"> <time datetime="2019-09-23T14:09:59+02:00"> 23 septembre 2019 à 14 h 09 min </time> </a></div></footer><div class="comment-content"><p>Reviens à la raison mon chère, il faut s&#8217;en prendre à l&#8217;équipe à l&#8217;origine de ces projets foireux et non au langage !<br /> Donc c&#8217;est toi qui as faux !</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-935' data-commentid="935" data-postid="3531" data-belowelement="div-comment-935" data-respondelement="respond" aria-label='Répondre à Mmmmmh ok'>Répondre</a></div></article></li><li id="comment-961" class="comment odd alt depth-2"><article id="div-comment-961" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/bff044b85a108377319e2fd03637980f?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bff044b85a108377319e2fd03637980f?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/bff044b85a108377319e2fd03637980f?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/bff044b85a108377319e2fd03637980f?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Julie xyz</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-961"> <time datetime="2019-09-23T20:35:43+02:00"> 23 septembre 2019 à 20 h 35 min </time> </a></div></footer><div class="comment-content"><p>C&#8217;est pas la faute de php, juste des développeurs qui n&#8217;essayent pas de coder proprement car ça demande de la réflexion et un peu d&#8217;effort</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-961' data-commentid="961" data-postid="3531" data-belowelement="div-comment-961" data-respondelement="respond" aria-label='Répondre à Julie xyz'>Répondre</a></div></article></li></ol></li><li id="comment-893" class="comment even thread-even depth-1 parent"><article id="div-comment-893" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/acabd93a27e43aedab281e666615b575?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/acabd93a27e43aedab281e666615b575?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/acabd93a27e43aedab281e666615b575?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/acabd93a27e43aedab281e666615b575?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Stephane Pellegrino</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-893"> <time datetime="2019-09-23T08:36:17+02:00"> 23 septembre 2019 à 8 h 36 min </time> </a></div></footer><div class="comment-content"><p>Super article.<br /> PHP souffre aussi de 2 petits problèmes :<br /> &#8211; Il reste cantonné à du Web<br /> &#8211; Si on programme comme une m***e, c&#8217;est facile de dire que c&#8217;est la faute de l&#8217;outil.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-893' data-commentid="893" data-postid="3531" data-belowelement="div-comment-893" data-respondelement="respond" aria-label='Répondre à Stephane Pellegrino'>Répondre</a></div></article><ol class="children"><li id="comment-896" class="comment odd alt depth-2"><article id="div-comment-896" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/bcf106eca5e80b003dd840966c2ee1da?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bcf106eca5e80b003dd840966c2ee1da?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/bcf106eca5e80b003dd840966c2ee1da?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/bcf106eca5e80b003dd840966c2ee1da?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn"><a href='https://www.linux-professionnel.net' rel='external nofollow' class='url'>QUINTON Eric</a></b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-896"> <time datetime="2019-09-23T09:55:56+02:00"> 23 septembre 2019 à 9 h 55 min </time> </a></div></footer><div class="comment-content"><p>Pas vraiment, je code maintenant des routines en ligne de commande pour traiter des fichiers bruts. Ça vaut les autres langages, et quand PHP est déjà présent dans ta machine, ça fonctionne très bien.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-896' data-commentid="896" data-postid="3531" data-belowelement="div-comment-896" data-respondelement="respond" aria-label='Répondre à QUINTON Eric'>Répondre</a></div></article></li></ol></li><li id="comment-894" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-894" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/e84da709d403e17e3389c92adf3ecca7?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e84da709d403e17e3389c92adf3ecca7?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/e84da709d403e17e3389c92adf3ecca7?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/e84da709d403e17e3389c92adf3ecca7?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Englebert J</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-894"> <time datetime="2019-09-23T09:29:25+02:00"> 23 septembre 2019 à 9 h 29 min </time> </a></div></footer><div class="comment-content"><p>super article ! merci<br /> Moi qui n&#8217;est que novice en la matière ,ton article m&#8217;a donné envie d&#8217;être curieux de me faire mon propre avis sur PHP !<br /> Sans doute que dans quelque années ( je vise loin oui ) , je détesterai &#8211; ou pas &#8211; PHP mais au moins pour mes raisons et pas pour faire comme &#8220;tout l&#8217;monde&#8221;</p><p>p.s: merci pour ces mêmes, gifs et blagues de Qualitées !  👏</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-894' data-commentid="894" data-postid="3531" data-belowelement="div-comment-894" data-respondelement="respond" aria-label='Répondre à Englebert J'>Répondre</a></div></article></li><li id="comment-897" class="comment odd alt thread-even depth-1"><article id="div-comment-897" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/919c6f7f1cfddbb3dd941be1045e7a8d?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/919c6f7f1cfddbb3dd941be1045e7a8d?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/919c6f7f1cfddbb3dd941be1045e7a8d?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/919c6f7f1cfddbb3dd941be1045e7a8d?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">LC</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-897"> <time datetime="2019-09-23T10:15:58+02:00"> 23 septembre 2019 à 10 h 15 min </time> </a></div></footer><div class="comment-content"><p>&#8220;développeur(euse)s&#8221;</p><p>Non.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-897' data-commentid="897" data-postid="3531" data-belowelement="div-comment-897" data-respondelement="respond" aria-label='Répondre à LC'>Répondre</a></div></article></li><li id="comment-898" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-898" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/c7f9d6c5d0cc4712159ec35d7b9eae85?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/c7f9d6c5d0cc4712159ec35d7b9eae85?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/c7f9d6c5d0cc4712159ec35d7b9eae85?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/c7f9d6c5d0cc4712159ec35d7b9eae85?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Nicolas D.</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-898"> <time datetime="2019-09-23T10:23:28+02:00"> 23 septembre 2019 à 10 h 23 min </time> </a></div></footer><div class="comment-content"><p>je code comme une merde en php, js, c#, java et delphi, mais plus vite en php !</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-898' data-commentid="898" data-postid="3531" data-belowelement="div-comment-898" data-respondelement="respond" aria-label='Répondre à Nicolas D.'>Répondre</a></div></article></li><li id="comment-899" class="comment odd alt thread-even depth-1"><article id="div-comment-899" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/b08047b021d67365d60c96962deb0e55?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/b08047b021d67365d60c96962deb0e55?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/b08047b021d67365d60c96962deb0e55?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/b08047b021d67365d60c96962deb0e55?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Crack la grenouille</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-899"> <time datetime="2019-09-23T10:26:51+02:00"> 23 septembre 2019 à 10 h 26 min </time> </a></div></footer><div class="comment-content"><p>Perso, ça m&#8217;a donné envie d&#8217;essayer juste pour me faire mon propre avis. Merci pour l&#8217;article.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-899' data-commentid="899" data-postid="3531" data-belowelement="div-comment-899" data-respondelement="respond" aria-label='Répondre à Crack la grenouille'>Répondre</a></div></article></li><li id="comment-903" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-903" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/05520587dbc587abe65f557e156b6e9f?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/05520587dbc587abe65f557e156b6e9f?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/05520587dbc587abe65f557e156b6e9f?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/05520587dbc587abe65f557e156b6e9f?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Fred</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-903"> <time datetime="2019-09-23T10:46:47+02:00"> 23 septembre 2019 à 10 h 46 min </time> </a></div></footer><div class="comment-content"><p>On pourrait presque reprendre le même avec C++ (la plupart des critiques du langage n&#8217;en connaissent généralement que sa version C++98).</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-903' data-commentid="903" data-postid="3531" data-belowelement="div-comment-903" data-respondelement="respond" aria-label='Répondre à Fred'>Répondre</a></div></article></li><li id="comment-904" class="comment odd alt thread-even depth-1"><article id="div-comment-904" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/e478625f4c487f7030d0972b89f9f937?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e478625f4c487f7030d0972b89f9f937?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/e478625f4c487f7030d0972b89f9f937?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/e478625f4c487f7030d0972b89f9f937?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Madrigal</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-904"> <time datetime="2019-09-23T10:48:56+02:00"> 23 septembre 2019 à 10 h 48 min </time> </a></div></footer><div class="comment-content"><p>Merci pour l&#8217;article!  Après des années, je vais justement devoir me remettre à PHP/Symphony et je découvre avec soulagement qu&#8217;il y a encore de la lumière au bout du tunnel. Après, je suis d&#8217;accord avec Jos : dans langage ouvert aux quatre vents, l&#8217;enfer c&#8217;est souvent le code des autres&#8230;</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-904' data-commentid="904" data-postid="3531" data-belowelement="div-comment-904" data-respondelement="respond" aria-label='Répondre à Madrigal'>Répondre</a></div></article></li><li id="comment-905" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-905" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/49a709ffce73101d49a4a0adbb7f14ca?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/49a709ffce73101d49a4a0adbb7f14ca?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/49a709ffce73101d49a4a0adbb7f14ca?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/49a709ffce73101d49a4a0adbb7f14ca?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Gelth</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-905"> <time datetime="2019-09-23T10:50:31+02:00"> 23 septembre 2019 à 10 h 50 min </time> </a></div></footer><div class="comment-content"><p>&#8220;Le PHP est le langage le plus utilisé au monde.&#8221; Heu non, plus depuis assez longtemps maintenant.<br /> <a href="https://spectrum.ieee.org/computing/software/the-top-programming-languages-2019" rel="nofollow">https://spectrum.ieee.org/computing/software/the-top-programming-languages-2019</a><br /> Ceci dit, php est encore très très utilisé.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-905' data-commentid="905" data-postid="3531" data-belowelement="div-comment-905" data-respondelement="respond" aria-label='Répondre à Gelth'>Répondre</a></div></article></li><li id="comment-906" class="comment odd alt thread-even depth-1"><article id="div-comment-906" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/ffa4356ec52bbae8c8a8b9cca282ebcc?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ffa4356ec52bbae8c8a8b9cca282ebcc?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ffa4356ec52bbae8c8a8b9cca282ebcc?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ffa4356ec52bbae8c8a8b9cca282ebcc?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Mouke</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-906"> <time datetime="2019-09-23T10:56:22+02:00"> 23 septembre 2019 à 10 h 56 min </time> </a></div></footer><div class="comment-content"><p>Bon article. J&#8217;ai jamais été un PHP hater et je bosse essentiellement sur cette techno. Et globalement bah t&#8217;as tout résumé : C&#8217;est un merdier qui a du évoluer pour devenir efficace. Y&#8217;a encore beaucoup de chemin à parcourir (notamment foutre un gros coup de balai et rendre cohérent les fonctions de base du langage), mais on y arrive tranquillement.</p><p>Et surtout, on y arrive sans surensemble. Le coeur de PHP évolue, c&#8217;est pas juste Zend et Symfony qui rajoute les features, laissant un PHP simple sans rien, c&#8217;est pas un pseudo langage qu&#8217;on compile en PHP&#8230; (Yep, c&#8217;est gratuit dans la gueule de Javascript ça)</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-906' data-commentid="906" data-postid="3531" data-belowelement="div-comment-906" data-respondelement="respond" aria-label='Répondre à Mouke'>Répondre</a></div></article></li><li id="comment-909" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-909" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/5773b181b685b444195f0a96293bd06b?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/5773b181b685b444195f0a96293bd06b?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/5773b181b685b444195f0a96293bd06b?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/5773b181b685b444195f0a96293bd06b?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Nickelé</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-909"> <time datetime="2019-09-23T11:09:20+02:00"> 23 septembre 2019 à 11 h 09 min </time> </a></div></footer><div class="comment-content"><p>C&#8217;est surtout le développement web qui est fondamentalement chiant 😛</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-909' data-commentid="909" data-postid="3531" data-belowelement="div-comment-909" data-respondelement="respond" aria-label='Répondre à Nickelé'>Répondre</a></div></article></li><li id="comment-916" class="comment odd alt thread-even depth-1"><article id="div-comment-916" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/feaaf215da2575d18ac82200215d09f7?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/feaaf215da2575d18ac82200215d09f7?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/feaaf215da2575d18ac82200215d09f7?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/feaaf215da2575d18ac82200215d09f7?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Kubi</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-916"> <time datetime="2019-09-23T11:51:31+02:00"> 23 septembre 2019 à 11 h 51 min </time> </a></div></footer><div class="comment-content"><p>J&#8217;utilise depuis PHP depuis 5 ans, et je me sens tellement bien. Comme présenté dans l&#8217;article, PHP est en évolution. La version 7 est un grand pas qui va redonner de la visibilité à ce langage. Je peux rajouter, que mes développeurs détestent PHP, parce qu&#8217;ils suivent la tendance tout simplement. Rare, les personnes qui vont se faire un avis sur le langage par le biais de l&#8217;expérience.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-916' data-commentid="916" data-postid="3531" data-belowelement="div-comment-916" data-respondelement="respond" aria-label='Répondre à Kubi'>Répondre</a></div></article></li><li id="comment-931" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-931" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/bfe3eb8147d93751dbd5b299c9cffde1?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/bfe3eb8147d93751dbd5b299c9cffde1?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/bfe3eb8147d93751dbd5b299c9cffde1?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/bfe3eb8147d93751dbd5b299c9cffde1?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn"><a href='https://thivinfo.com/' rel='external nofollow' class='url'>Sebastien</a></b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-931"> <time datetime="2019-09-23T13:43:31+02:00"> 23 septembre 2019 à 13 h 43 min </time> </a></div></footer><div class="comment-content"><p>&#8220;le sortir de l’équation seulement à cause de sa réputation et aussi con que désespérant. Et y’a plein de gens désespérants.&#8221;<br /> Merci Mehdi!<br /> Alors qu&#8217;en tu es dev PHP et spécialisé dans WordPress&#8230; je te fais pas de dessin&#8230;</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-931' data-commentid="931" data-postid="3531" data-belowelement="div-comment-931" data-respondelement="respond" aria-label='Répondre à Sebastien'>Répondre</a></div></article></li><li id="comment-941" class="comment odd alt thread-even depth-1 parent"><article id="div-comment-941" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/c4c6db3fc82087b9ccf0570c5fbc839b?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/c4c6db3fc82087b9ccf0570c5fbc839b?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/c4c6db3fc82087b9ccf0570c5fbc839b?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/c4c6db3fc82087b9ccf0570c5fbc839b?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Aurélien JOLY</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-941"> <time datetime="2019-09-23T14:50:57+02:00"> 23 septembre 2019 à 14 h 50 min </time> </a></div></footer><div class="comment-content"><p>Sorry je suis orthographe nazi, j&#8217;ai pas réussi couper mon cerveau avant quelques lignes, donc il doit rester quelques coquilles :</p><p>&#8220;Y’en a plein d’autres c’est accablant et je te parle même pas de ce qui se passe sur [Reddit]&#8221;<br /> &#8220;On est là pour [discuter], pose cette arme. Bon maintenant au contraire si tu [hais] PHP avec passion : prends des pop-corns et [assied] toi [confortablement] t’es au bon endroit.&#8221;</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-941' data-commentid="941" data-postid="3531" data-belowelement="div-comment-941" data-respondelement="respond" aria-label='Répondre à Aurélien JOLY'>Répondre</a></div></article><ol class="children"><li id="comment-948" class="comment byuser comment-author-vooodoo bypostauthor even depth-2"><article id="div-comment-948" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">jesuisundev</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-948"> <time datetime="2019-09-23T16:13:35+02:00"> 23 septembre 2019 à 16 h 13 min </time> </a></div></footer><div class="comment-content"><p>C&#8217;est corrigé. Merci beaucoup Aurélien !</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-948' data-commentid="948" data-postid="3531" data-belowelement="div-comment-948" data-respondelement="respond" aria-label='Répondre à jesuisundev'>Répondre</a></div></article></li></ol></li><li id="comment-942" class="comment odd alt thread-odd thread-alt depth-1"><article id="div-comment-942" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/8d6b0c03fe8ac4d27a2674b54b34e0b2?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8d6b0c03fe8ac4d27a2674b54b34e0b2?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/8d6b0c03fe8ac4d27a2674b54b34e0b2?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/8d6b0c03fe8ac4d27a2674b54b34e0b2?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn"><a href='http://vnunnari.fr' rel='external nofollow' class='url'>Vincent Nunnari</a></b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-942"> <time datetime="2019-09-23T14:53:45+02:00"> 23 septembre 2019 à 14 h 53 min </time> </a></div></footer><div class="comment-content"><p>Je suis DEV, j&#8217;aime le Php et je le revendique. Bon d&#8217;accord&#8230;je suis fullstack et je fais presque tout from Scratch c&#8217;est sûrement pour ça que je m&#8217;éclate autant. La classe de bosser chez Ubi Soft au passage. Petit Veinard 😁</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-942' data-commentid="942" data-postid="3531" data-belowelement="div-comment-942" data-respondelement="respond" aria-label='Répondre à Vincent Nunnari'>Répondre</a></div></article></li><li id="comment-944" class="comment even thread-even depth-1"><article id="div-comment-944" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/07ceb097f3b8406350ba8127d1fb8ad8?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/07ceb097f3b8406350ba8127d1fb8ad8?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/07ceb097f3b8406350ba8127d1fb8ad8?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/07ceb097f3b8406350ba8127d1fb8ad8?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Rukhazon</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-944"> <time datetime="2019-09-23T15:34:41+02:00"> 23 septembre 2019 à 15 h 34 min </time> </a></div></footer><div class="comment-content"><p>Heu, le langage le plus détesté n&#8217;est pas le JavaScript ?</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-944' data-commentid="944" data-postid="3531" data-belowelement="div-comment-944" data-respondelement="respond" aria-label='Répondre à Rukhazon'>Répondre</a></div></article></li><li id="comment-951" class="comment odd alt thread-odd thread-alt depth-1"><article id="div-comment-951" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/ddf1c952fc214ecda7c96d9146994941?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ddf1c952fc214ecda7c96d9146994941?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ddf1c952fc214ecda7c96d9146994941?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ddf1c952fc214ecda7c96d9146994941?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Florence Delattre</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-951"> <time datetime="2019-09-23T17:19:14+02:00"> 23 septembre 2019 à 17 h 19 min </time> </a></div></footer><div class="comment-content"><p>Par moi oui, c&#8217;est JS le plus détesté 😜</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-951' data-commentid="951" data-postid="3531" data-belowelement="div-comment-951" data-respondelement="respond" aria-label='Répondre à Florence Delattre'>Répondre</a></div></article></li><li id="comment-952" class="comment even thread-even depth-1"><article id="div-comment-952" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/0086f909674aaee544284b3854a2528b?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0086f909674aaee544284b3854a2528b?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/0086f909674aaee544284b3854a2528b?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/0086f909674aaee544284b3854a2528b?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">haxes</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-952"> <time datetime="2019-09-23T17:24:08+02:00"> 23 septembre 2019 à 17 h 24 min </time> </a></div></footer><div class="comment-content"><p>Essentiellement développeur JS et venant du monde du .Net, du Scala et du Java je n&#8217;avais effectivement pas fait de PHP depuis sa version 4 jusqu&#8217;à cette année. Et pourtant j&#8217;ai toujours autant de mal à l&#8217;apprécier..</p><p>J&#8217;ai toujours l&#8217;impression le monde du PHP (langage + frameworks/outils) est en retard sur celui des autres langage. Peut-être que je n&#8217;utilise pas les bons outils ou peut-être est-ce juste une peur du PHP restée enfouie.</p><p>Mais de l&#8217;utilisation que j&#8217;en ai et surtout de ce que j&#8217;en vois quotidiennement en code review, Symfony &amp; co n&#8217;apportent pas toute la puissance d&#8217;un projet java avec une stack spring (Boot / Cloud / WS) par exemple. Cependant c&#8217;est certain pour un petit projet c&#8217;est largement suffisant, pas besoin de déployer une usine à gaz.</p><p>Et puis concernant langage lui même, même si j&#8217;ai eu l&#8217;agréable surprise de voir que les arrow functions arrivent *enfin*, le language me paraît toujours un peu trop verbeux et peu agréable à lire et à utiliser.<br /> Et ce, en partant de petits détails comme l&#8217;utilisation de `$` devant les variables, les `::` et `-&gt;` là où on utilise très bien le `.` dans d&#8217;autres langages, le `array_map` (quelle horreur d&#8217;avoir à écrire ça, là où le `.map` des autres langages ensoleille ma journée, même si oui, il y une lib pour pourvoir faire la même chose en PHP),  l&#8217;utilisation du `fn` pour déclarer une arrow function&#8230;<br /> Des détails certes, venant de son historique et de sa conception, mais qui le rendent selon moi moins &#8220;developer friendly&#8221;</p><p>Bref, voilà pourquoi je &#8220;déteste PHP&#8221;</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-952' data-commentid="952" data-postid="3531" data-belowelement="div-comment-952" data-respondelement="respond" aria-label='Répondre à haxes'>Répondre</a></div></article></li><li id="comment-953" class="comment odd alt thread-odd thread-alt depth-1 parent"><article id="div-comment-953" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Jerome</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-953"> <time datetime="2019-09-23T17:40:21+02:00"> 23 septembre 2019 à 17 h 40 min </time> </a></div></footer><div class="comment-content"><p>Amusant 😉</p><p> Je ne pense pas que les dev detestent PHP (ou pas plus que le javascript), c&#8217;est l&#8217;évolution rapide des technologies (donc des langages) qui fait doucement glisser le php vers la sortie, je m&#8217;explique: depuis le web 2.0 avec XMLHttpRequest, l&#8217;ES6 (2015), le moteur V8 de Google pour nodeJS, le TypeScript de Microsoft adopté par Angular (framework Google &#8211; Single Page Application), le framwork React de Facebook &#8230;</p><p> Tout est fait (en tout cas chez Microsoft et Google) pour transformer les sites web en WebApps et maintenant en PWA (mobile oblige). Mon avis: l&#8217;association des deux géants du web se concentre avant tout sur l&#8217;affaiblissement du Java (et donc d&#8217;Oracle). Le backend tel qu&#8217;on le pratiquait (il y a quelques années) glisse vers le frontend ((JS) parce que seul maitre dans un navigateur), le backend évolue vers un monde d&#8217;API nécessitant des langages plus rapides et facilitant le multi-theading (comme le GO ou le RUST). Des API ne répondant que pour du transfert de data (JSON) à des requetes GET, POST, DELETE &#8230;</p><p> Bref, le web se transforme et de nombreux langages vont en faire les frais selon moi (Java, PHP, Ruby). Python tire son épingle du jeux car c&#8217;est le langage de scripts de référence des distributions Linux, utilisé également pour l&#8217;IA ou le Big Data. Une PWA peut être empaquetée (Electron, Cordova &#8230;) et fonctionner su n&#8217;importe quel OS (ex VSCODE de MS). Il ne faut pas oublier le monde des objets connectés qui enveront des données aux API (plus besoin de page avec des logos, plus de présentation mais de la vitesse uniquement 4G/5G). Les applications web &amp; mobiles permettants de piloter ses API. Je mets un bemol tout de même, il y aura toujours des sites web à l&#8217;ancienne mais moins nombreux. Les iniatives des GAFAM sont d&#8217;accélerer le web et même si cela prend quelques années, c&#8217;est marche ou crève (même Apple rejoint les autres).</p><p> C&#8217;est ma vison et j&#8217;aimerai bien connaître vos avis et les nouveautés permettant au PHP de résister à une évolution du web et des technologies. Il y a 10 ans je faisais un peu de PHP, aujourd&#8217;hui, je me forme sur GO et JS (JS pas franchement par choix mais plus par obligation). Voilà, maintenant faites moi réfléchir 😉</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-953' data-commentid="953" data-postid="3531" data-belowelement="div-comment-953" data-respondelement="respond" aria-label='Répondre à Jerome'>Répondre</a></div></article><ol class="children"><li id="comment-954" class="comment even depth-2 parent"><article id="div-comment-954" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/f32774bbac7cb0fe573afd23ca2aa1f5?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/f32774bbac7cb0fe573afd23ca2aa1f5?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/f32774bbac7cb0fe573afd23ca2aa1f5?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/f32774bbac7cb0fe573afd23ca2aa1f5?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Xann</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-954"> <time datetime="2019-09-23T18:30:22+02:00"> 23 septembre 2019 à 18 h 30 min </time> </a></div></footer><div class="comment-content"><p>Mais PHP est tout à fait capable de faire tourner une API REST, vu que de base c&#8217;est un langage qui réponds à des requêtes HTTP.<br /> Du coup je vois pas en quoi ton argumentaire pousse PHP vers la sortie, j&#8217;ai plus l&#8217;impression que c&#8217;est une évolution de son utilisation qui est en train de se passer (ce qui est effectivement clair)</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-954' data-commentid="954" data-postid="3531" data-belowelement="div-comment-954" data-respondelement="respond" aria-label='Répondre à Xann'>Répondre</a></div></article><ol class="children"><li id="comment-962" class="comment odd alt depth-3"><article id="div-comment-962" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Kevin</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-962"> <time datetime="2019-09-23T20:40:01+02:00"> 23 septembre 2019 à 20 h 40 min </time> </a></div></footer><div class="comment-content"><p>Si on suit ton raisonnement, le JS glisserait aussi vers la sortie. La V8 de Google est une évolution des perfs(pour faire court), le typescript permet de combler des lacunes du JS, etc. Au final, le JS est un vieux langage qui s&#8217;est modernisé. Tout comme le PHP aujourd&#8217;hui. Après il faut choisir le langage en fonction des besoins/ressources/etc. Les deux langages sont top.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-962' data-commentid="962" data-postid="3531" data-belowelement="div-comment-962" data-respondelement="respond" aria-label='Répondre à Kevin'>Répondre</a></div></article></li></ol></li></ol></li><li id="comment-958" class="comment even thread-even depth-1"><article id="div-comment-958" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/09be1218ebebd052002e2917acec76bd?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/09be1218ebebd052002e2917acec76bd?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/09be1218ebebd052002e2917acec76bd?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/09be1218ebebd052002e2917acec76bd?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Villers mickaël</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-958"> <time datetime="2019-09-23T19:40:35+02:00"> 23 septembre 2019 à 19 h 40 min </time> </a></div></footer><div class="comment-content"><p>Personnellement ce que j&#8217;aime pas avec php c&#8217;est qu&#8217;il faut avoir du cache pour améliorer les perfs et du coup en fait ne pas exécuter du php pour avoir un php plus rapide. Comme l&#8217;installation de opcache est presque un pré requis pour utiliser un framework style laravel ou symfony</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-958' data-commentid="958" data-postid="3531" data-belowelement="div-comment-958" data-respondelement="respond" aria-label='Répondre à Villers mickaël'>Répondre</a></div></article></li><li id="comment-959" class="comment odd alt thread-odd thread-alt depth-1"><article id="div-comment-959" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/1d6d70cf6ca581492d525f74f4652d53?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1d6d70cf6ca581492d525f74f4652d53?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/1d6d70cf6ca581492d525f74f4652d53?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/1d6d70cf6ca581492d525f74f4652d53?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Kyori</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-959"> <time datetime="2019-09-23T20:15:15+02:00"> 23 septembre 2019 à 20 h 15 min </time> </a></div></footer><div class="comment-content"><p>Perso je dev 90% du temps en php et qui plus est c&#8217;est du dev pour des amelio / plug-ins WP&#8230; J&#8217;ai testé d&#8217;autres technos back et aucune ne me satisfait autant que le php&#8230; Pas par refus loin de la mais nous avons tous nos affinités 🙂</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-959' data-commentid="959" data-postid="3531" data-belowelement="div-comment-959" data-respondelement="respond" aria-label='Répondre à Kyori'>Répondre</a></div></article></li><li id="comment-960" class="comment even thread-even depth-1 parent"><article id="div-comment-960" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/324237c1f4ab0fad87c12c9801f609d1?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/324237c1f4ab0fad87c12c9801f609d1?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/324237c1f4ab0fad87c12c9801f609d1?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/324237c1f4ab0fad87c12c9801f609d1?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Becaree</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-960"> <time datetime="2019-09-23T20:17:42+02:00"> 23 septembre 2019 à 20 h 17 min </time> </a></div></footer><div class="comment-content"><p>Alors Php est lent, oui, parce que y a pas de possibilité de multithreading ou d asynchrone, le fait qu il soit typé ne change en rien ce probleme qui est partiellement resolu par python et javascript qui peuvent etre eux memes typés. Mais surtout Php from scratch c est une horreur au niveau de l API. L api python contient quasiment la totalité de celle de php mais on peut faire du scripting ce qui est un gros plus, quand a celle de js, elle evolue grce a ecmascript et node. Un moment utilisé des librairies et frameworks, c est bien, mais une librairie standard c est le plus important. Perso ce qui me derange le plus c est la sytaxe et le fait que ce soit que tu puisses pas scripté. Tres bonne review de Jerome!</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-960' data-commentid="960" data-postid="3531" data-belowelement="div-comment-960" data-respondelement="respond" aria-label='Répondre à Becaree'>Répondre</a></div></article><ol class="children"><li id="comment-966" class="comment odd alt depth-2"><article id="div-comment-966" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/8abcbcb7daec86d2b51b3d91341408c7?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Kevin</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-966"> <time datetime="2019-09-23T20:59:37+02:00"> 23 septembre 2019 à 20 h 59 min </time> </a></div></footer><div class="comment-content"><p>Regarde Swoole/PHP</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-966' data-commentid="966" data-postid="3531" data-belowelement="div-comment-966" data-respondelement="respond" aria-label='Répondre à Kevin'>Répondre</a></div></article></li></ol></li><li id="comment-963" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-963" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/dd7e66e6166cae078bf98e372eea54e0?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/dd7e66e6166cae078bf98e372eea54e0?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/dd7e66e6166cae078bf98e372eea54e0?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/dd7e66e6166cae078bf98e372eea54e0?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn"><a href='https://inescoin.org' rel='external nofollow' class='url'>Moon</a></b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-963"> <time datetime="2019-09-23T20:44:48+02:00"> 23 septembre 2019 à 20 h 44 min </time> </a></div></footer><div class="comment-content"><p>J&#8217;aime telement le PHP que j&#8217;ai creer un cms (doorgets) puis un blockchain (inescoin), c&#8217;est le seul language qui me permet de partir d&#8217;une feuille blanche pour en faire une oeuvre sortir de mon imagination, avec les restrictions des autres aures languages j&#8217;ai l&#8217;impression que la boite et toujours la même et franchement c&#8217;est pas du code&#8230;</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-963' data-commentid="963" data-postid="3531" data-belowelement="div-comment-963" data-respondelement="respond" aria-label='Répondre à Moon'>Répondre</a></div></article></li><li id="comment-964" class="comment odd alt thread-even depth-1"><article id="div-comment-964" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/34b10cb0b531c8c9247a1b0bc19b54af?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/34b10cb0b531c8c9247a1b0bc19b54af?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/34b10cb0b531c8c9247a1b0bc19b54af?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/34b10cb0b531c8c9247a1b0bc19b54af?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">PasDeçaIci</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-964"> <time datetime="2019-09-23T20:46:37+02:00"> 23 septembre 2019 à 20 h 46 min </time> </a></div></footer><div class="comment-content"><p>&gt;&gt;Et y’a plein de gens désespérants.<br /> Bah parfois à lire ton blog, il n&#8217;est pas loin de l&#8217;être, sans que tu le veuilles pour autant.<br /> Pour aimer ce métier, y a pas à dire faut aimer les gens.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-964' data-commentid="964" data-postid="3531" data-belowelement="div-comment-964" data-respondelement="respond" aria-label='Répondre à PasDeçaIci'>Répondre</a></div></article></li><li id="comment-967" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-967" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/503e8f1336dac36a841e3a43e58e3b8a?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Jerome</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-967"> <time datetime="2019-09-23T21:46:48+02:00"> 23 septembre 2019 à 21 h 46 min </time> </a></div></footer><div class="comment-content"><p>Je ne connaissais pas &#8220;Swoole/PHP&#8221;, c&#8217;est marrant on dirait du node.js  😉 et pas très loin du Golang finalement</p><p><code><br /> $server = new swoole_websocket_server("127.0.0.1", 9502);<br /> $server-&gt;on('open', function($server, $req) {<br /> echo "connection open: {$req-&gt;fd}\n";<br /> });<br /> </code><br /> Il semble que de nombreux langages évoluent dans le même sens ( serveur tcp/http, web socket, &#8230;), et donc API, API   😉<br /> Merci pour vos remarques.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-967' data-commentid="967" data-postid="3531" data-belowelement="div-comment-967" data-respondelement="respond" aria-label='Répondre à Jerome'>Répondre</a></div></article></li><li id="comment-970" class="comment odd alt thread-even depth-1"><article id="div-comment-970" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/cf34305f2de6ef3f1b27aeb8db253012?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/cf34305f2de6ef3f1b27aeb8db253012?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/cf34305f2de6ef3f1b27aeb8db253012?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/cf34305f2de6ef3f1b27aeb8db253012?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn">Nox</b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-970"> <time datetime="2019-09-24T00:26:34+02:00"> 24 septembre 2019 à 0 h 26 min </time> </a></div></footer><div class="comment-content"><p>Franchement, je fais des applis JavaScript + PHP depuis 10ans, et ces langages n&#8217;ont jamais été un frein au développement. Les seules limites sont les miennes, mes connaissances et compétences.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-970' data-commentid="970" data-postid="3531" data-belowelement="div-comment-970" data-respondelement="respond" aria-label='Répondre à Nox'>Répondre</a></div></article></li><li id="comment-971" class="comment even thread-odd thread-alt depth-1"><article id="div-comment-971" class="comment-body"><footer class="comment-meta"><div class="comment-author vcard"> <noscript><img alt='' src='https://secure.gravatar.com/avatar/d3e15c9a04c7bab062b291f28eef07d9?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d3e15c9a04c7bab062b291f28eef07d9?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/d3e15c9a04c7bab062b291f28eef07d9?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/d3e15c9a04c7bab062b291f28eef07d9?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' /> <b class="fn"><a href='http://nawoka.fr' rel='external nofollow' class='url'>John</a></b> <span class="says">dit :</span></div><div class="comment-metadata"> <a href="https://www.jesuisundev.com/pourquoi-les-developpeurs-detestent-php/#comment-971"> <time datetime="2019-09-24T01:13:51+02:00"> 24 septembre 2019 à 1 h 13 min </time> </a></div></footer><div class="comment-content"><p>Je déteste PHP non pas par élitisme mais parce que j&#8217;ai l&#8217;impression que c&#8217;est un language is fourre tout bourrer d&#8217;inconstance. Coder c&#8217;est avoir des patterns bien précis qui garantissent la constance de ton programme quelque soit les conditions. Or, avec PHP c&#8217;est très peu possible.</p><p>Après, moi je viens du monde de Python donc PHP grosso modo me donne mal à la tête car peu ou pas assez proche du language parler aussi.</p><p>Soit dit en passant, monter un site perso facilement y&#8217;a pas que PHP qui le fait. Flask (Python) avec un fichier main et un template index tu peux faire de même avec une quinzaine de ligne de code. Après c&#8217;est pas hyper connu par rapport à Django.</p></div><div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-971' data-commentid="971" data-postid="3531" data-belowelement="div-comment-971" data-respondelement="respond" aria-label='Répondre à John'>Répondre</a></div></article></li></ol></div><div id="respond" class="comment-respond"><h2 id="reply-title" class="comment-reply-title"><span>T&#039;en penses quoi ?</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/pourquoi-les-developpeurs-detestent-php/#respond" style="display:none;">Annulé</a></small></h2><form action="https://www.jesuisundev.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published. Required fields are marked *</p><p class="comment-form-comment"><label for="comment">Commentaire</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Nom <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Adresse de messagerie <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Site web</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Enregistrer mon nom, mon e-mail et mon site web dans le navigateur pour mon prochain commentaire.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post" /> <input type='hidden' name='comment_post_ID' value='3531' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0e00876ae1" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="42"/></p></form></div></div><div class="bwp-related-posts bwp-show-3-related-posts"><h2 class="bwp-container-title">Et sinon</h2><div class="bwp-related-posts-list clearfix"><article id="bwp-post-1977" class="post-1977 post type-post status-publish format-standard has-post-thumbnail hentry category-backend category-developpement category-developpeur category-developpeuse category-frontend category-fullstack category-javascript category-php-2 category-web tag-backend tag-developpement tag-developpeur tag-developpeuse tag-frontend tag-fullstack tag-guru tag-javascript tag-ninja tag-php tag-rockstar tag-web"><div class="bwp-post-wrap"><div class="bwp-post-content"><div class="bwp-post-date"> <a href="https://www.jesuisundev.com/2019/02/03/"> <span class="date updated">3 février 2019</span> </a></div><h3 class="bwp-post-title entry-title"> <a href="https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/">Tu n&#8217;es pas un(e) développeur(euse) rockstar</a></h3><div class="bwp-post-excerpt entry-content"><p>Depuis le jour où tu as commencé à coder on t&#8217;a fait comprendre que ton seul but c&#8217;était de devenir un(e) développeur(euse) rockstar. Bientôt tu seras un ninja, un guru, un jedi ou une autre connerie du genre.</p></div><div class="clearfix"><div class="bwp-post-author"><figure class="bwp-post-author-avatar"> <a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev"> <noscript><img alt='jesuisundev' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' /></noscript><img alt='jesuisundev' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2072%2072%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-72 photo' height='72' width='72' /><div class="bwp-avatar-bg-overlay"></div> </a></figure><div class="bwp-post-author-name"> <a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev" rel="author"> <span class="vcard author"> <span class="fn">jesuisundev</span> </span> </a></div></div><div class="bwp-post-icons bwp-no-post-author"><div class="bwp-post-share"> <a href="#" rel="nofollow" class="bwp-post-share-icon"> <i class="fas fa-share-alt"></i> </a><div class="bwp-post-share-list-wrap"><ul class="bwp-post-share-list list-unstyled clearfix"><li> <a href="https://twitter.com/share?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&text=Tu n&#8217;es pas un(e) développeur(euse) rockstar" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&text=Tu n&#8217;es pas un(e) développeur(euse) rockstar', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-twitter"></i> </a></li><li> <a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&t=Tu%20n%26%238217%3Bes%20pas%20un%28e%29%20d%C3%A9veloppeur%28euse%29%20rockstar" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&t=Tu%20n%26%238217%3Bes%20pas%20un%28e%29%20d%C3%A9veloppeur%28euse%29%20rockstar', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-facebook-f"></i> </a></li><li> <a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&media=https://www.jesuisundev.com/wp-content/uploads/2019/01/souffrir-1.gif&description=Tu%20n%26%238217%3Bes%20pas%20un%28e%29%20d%C3%A9veloppeur%28euse%29%20rockstar" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&media=https://www.jesuisundev.com/wp-content/uploads/2019/01/souffrir-1.gif&description=Tu%20n%26%238217%3Bes%20pas%20un%28e%29%20d%C3%A9veloppeur%28euse%29%20rockstar', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-pinterest-p"></i> </a></li><li> <a href="https://vk.com/share.php?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-vk"></i> </a></li><li> <a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&title=Tu%20n%26%238217%3Bes%20pas%20un%28e%29%20d%C3%A9veloppeur%28euse%29%20rockstar" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/tu-nes-pas-un-developpeur-rockstar/&title=Tu%20n%26%238217%3Bes%20pas%20un%28e%29%20d%C3%A9veloppeur%28euse%29%20rockstar', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-reddit-alien"></i> </a></li></ul></div></div></div></div></div></div></article><article id="bwp-post-2562" class="post-2562 post type-post status-publish format-standard has-post-thumbnail hentry category-deep-learning category-developpement category-developpeur category-developpeuse category-ia category-intelligence-artificielle category-internet category-machine-learning tag-deep-learning tag-developpement tag-developpeur tag-developpeuse tag-ia tag-intelligence-artificielle tag-machine-learning"><div class="bwp-post-wrap"><div class="bwp-post-content"><div class="bwp-post-date"> <a href="https://www.jesuisundev.com/2019/04/15/"> <span class="date updated">15 avril 2019</span> </a></div><h3 class="bwp-post-title entry-title"> <a href="https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/">Comprendre l&#8217;intelligence artificielle en 10 minutes</a></h3><div class="bwp-post-excerpt entry-content"><p>On entend beaucoup parler d&#8217;intelligence artificielle mais concrètement comment ça marche ? La machine est-t-elle réellement capable de penser ?</p></div><div class="clearfix"><div class="bwp-post-author"><figure class="bwp-post-author-avatar"> <a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev"> <noscript><img alt='jesuisundev' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' /></noscript><img alt='jesuisundev' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2072%2072%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-72 photo' height='72' width='72' /><div class="bwp-avatar-bg-overlay"></div> </a></figure><div class="bwp-post-author-name"> <a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev" rel="author"> <span class="vcard author"> <span class="fn">jesuisundev</span> </span> </a></div></div><div class="bwp-post-icons bwp-no-post-author"><div class="bwp-post-share"> <a href="#" rel="nofollow" class="bwp-post-share-icon"> <i class="fas fa-share-alt"></i> </a><div class="bwp-post-share-list-wrap"><ul class="bwp-post-share-list list-unstyled clearfix"><li> <a href="https://twitter.com/share?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&text=Comprendre l&#8217;intelligence artificielle en 10 minutes" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&text=Comprendre l&#8217;intelligence artificielle en 10 minutes', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-twitter"></i> </a></li><li> <a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&t=Comprendre%20l%26%238217%3Bintelligence%20artificielle%20en%2010%20minutes" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&t=Comprendre%20l%26%238217%3Bintelligence%20artificielle%20en%2010%20minutes', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-facebook-f"></i> </a></li><li> <a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&media=https://www.jesuisundev.com/wp-content/uploads/2019/04/sophia-robot-1-ez.gif&description=Comprendre%20l%26%238217%3Bintelligence%20artificielle%20en%2010%20minutes" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&media=https://www.jesuisundev.com/wp-content/uploads/2019/04/sophia-robot-1-ez.gif&description=Comprendre%20l%26%238217%3Bintelligence%20artificielle%20en%2010%20minutes', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-pinterest-p"></i> </a></li><li> <a href="https://vk.com/share.php?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-vk"></i> </a></li><li> <a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&title=Comprendre%20l%26%238217%3Bintelligence%20artificielle%20en%2010%20minutes" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/comprendre-intelligence-artificielle-en-10-minutes/&title=Comprendre%20l%26%238217%3Bintelligence%20artificielle%20en%2010%20minutes', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-reddit-alien"></i> </a></li></ul></div></div></div></div></div></div></article><article id="bwp-post-1674" class="post-1674 post type-post status-publish format-standard has-post-thumbnail hentry category-backend category-developpement category-developpeur category-developpeuse category-expat category-expatriation category-expatrie category-frontend category-fullstack category-pvt category-pvtistes category-web tag-backend tag-developpement tag-developpeur tag-developpeuse tag-emploi tag-expat tag-expatriation tag-expatrie tag-frontend tag-fullstack tag-pvt tag-pvtistes tag-web"><div class="bwp-post-wrap"><div class="bwp-post-content"><div class="bwp-post-date"> <a href="https://www.jesuisundev.com/2019/01/21/"> <span class="date updated">21 janvier 2019</span> </a></div><h3 class="bwp-post-title entry-title"> <a href="https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/">Pourquoi un développeur devrait s&#8217;expatrier</a></h3><div class="bwp-post-excerpt entry-content"><p>Aujourd&#8217;hui on va se concentrer sur le pourquoi tu devrais prendre un avion et tenter l&#8217;aventure. Et vindieu accroche toi va avoir des turbulences.</p></div><div class="clearfix"><div class="bwp-post-author"><figure class="bwp-post-author-avatar"> <a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev"> <noscript><img alt='jesuisundev' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' /></noscript><img alt='jesuisundev' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2072%2072%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-72 photo' height='72' width='72' /><div class="bwp-avatar-bg-overlay"></div> </a></figure><div class="bwp-post-author-name"> <a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev" rel="author"> <span class="vcard author"> <span class="fn">jesuisundev</span> </span> </a></div></div><div class="bwp-post-icons bwp-no-post-author"><div class="bwp-post-share"> <a href="#" rel="nofollow" class="bwp-post-share-icon"> <i class="fas fa-share-alt"></i> </a><div class="bwp-post-share-list-wrap"><ul class="bwp-post-share-list list-unstyled clearfix"><li> <a href="https://twitter.com/share?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&text=Pourquoi un développeur devrait s&#8217;expatrier" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&text=Pourquoi un développeur devrait s&#8217;expatrier', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-twitter"></i> </a></li><li> <a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&t=Pourquoi%20un%20d%C3%A9veloppeur%20devrait%20s%26%238217%3Bexpatrier" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&t=Pourquoi%20un%20d%C3%A9veloppeur%20devrait%20s%26%238217%3Bexpatrier', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;"> <i class="fab fa-facebook-f"></i> </a></li><li> <a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&media=https://www.jesuisundev.com/wp-content/uploads/2019/01/leaving-ez.gif&description=Pourquoi%20un%20d%C3%A9veloppeur%20devrait%20s%26%238217%3Bexpatrier" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&media=https://www.jesuisundev.com/wp-content/uploads/2019/01/leaving-ez.gif&description=Pourquoi%20un%20d%C3%A9veloppeur%20devrait%20s%26%238217%3Bexpatrier', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-pinterest-p"></i> </a></li><li> <a href="https://vk.com/share.php?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-vk"></i> </a></li><li> <a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&title=Pourquoi%20un%20d%C3%A9veloppeur%20devrait%20s%26%238217%3Bexpatrier" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/pourquoi-un-developpeur-devrait-sexpatrier/&title=Pourquoi%20un%20d%C3%A9veloppeur%20devrait%20s%26%238217%3Bexpatrier', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;"> <i class="fab fa-reddit-alien"></i> </a></li></ul></div></div></div></div></div></div></article></div></div></div></div></section><footer id="bwp-footer"><div class="container"><div class="bwp-footer-container clearfix"><div class="bwp-footer-text"> Copyright - Je suis un dev - 2019</div><div class="bwp-footer-social-links clearfix"> <a href="https://twitter.com/jesuisundev" target="_blank" rel="noopener"> <i class="fab fa-twitter"></i> </a> <a href="mailto:admin@jesuisundev.com" rel="noopener"> <i class="far fa-envelope"></i> </a> <a href="https://www.jesuisundev.com/feed/" target="_blank" rel="noopener"> <i class="fas fa-rss-square"></i> </a></div></div></div><script>setTimeout(function(){ jQuery( "#disqus_thread iframe:first-child" ).hide(); jQuery( "#disqus_thread .discovery-post .top-comment" ).hide(); }, 3000);</script></footer> <noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://www.jesuisundev.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js'></script><script type='text/javascript'>var nimboCookiesInformationData = {"cookiesInfoWindow":"hide","cookiesInfoOnMobile":"hidden-window"};</script> <script type='text/javascript'>var nimboSocialMediaData = {"ajaxURL":"https:\/\/www.jesuisundev.com\/wp-admin\/admin-ajax.php","ajaxNonce":"9bc034454d"};</script> <script type='text/javascript'>var nimboData = {"isMobile":"false","isSingular":"true","isAdminBarShowing":"false","headerType":"header-two-rows","stickyHeader":"off","logoType":"image","menuType":"hidden-menu","colorSwitch":"on","darkColorSwitchIconType":"sun","dropdownSearch":"hide","masonryColumnWidth":".bwp-col-3-default","toTopButton":"show","colorSwitchCookies":"on"};</script> <script type='text/javascript' src='https://www.jesuisundev.com/wp-content/cache/autoptimize/js/autoptimize_single_8decb0ce7eb8097d463a77d859a02725.js'></script> <script type='text/javascript' src='https://www.jesuisundev.com/wp-content/plugins/enlighter/resources/EnlighterJS.min.js'></script> <script type="text/javascript">EnlighterJS_Config = {"selector":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"language":"js","theme":"atomic","indent":2,"hover":"hoverEnabled","showLinenumbers":true,"rawButton":true,"infoButton":true,"windowButton":true,"rawcodeDoubleclick":false,"grouping":true,"cryptex":{"enabled":false,"email":"mail@example.tld"}};!function(){var a=function(a){var b="Enlighter Error: ";console.error?console.error(b+a):console.log&&console.log(b+a)};return window.addEvent?"undefined"==typeof EnlighterJS?void a("Javascript Resources not loaded yet!"):"undefined"==typeof EnlighterJS_Config?void a("Configuration not loaded yet!"):void window.addEvent("domready",function(){EnlighterJS.Util.Init(EnlighterJS_Config.selector.block,EnlighterJS_Config.selector.inline,EnlighterJS_Config)}):void a("MooTools Framework not loaded yet!")}();;</script><script type="text/javascript" defer src="https://www.jesuisundev.com/wp-content/cache/autoptimize/js/autoptimize_d0374b93f8f2d4f1aa5ce46d094b67b6.js"></script></body></html>