﻿<!doctype html>
<html lang="fr-FR">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">

	<script data-cfasync="false" id="ao_optimized_gfonts_config">WebFontConfig={google:{families:["Lora:400,400i,700,700i","Source Sans Pro:400,600,700","Playfair Display:400,400i","PT Sans:400,700"] },classes:false, events:false, timeout:1500};</script><link rel="profile" href="https://gmpg.org/xfn/11">
	<link rel="pingback" href="">

	<link rel="preload" as="style" media="all" href="https://www.jesuisundev.com/wp-content/cache/autoptimize/css/autoptimize_cf2b811069ad5527268492bc99155d00.css" onload="this.onload=null;this.rel='stylesheet'" /><noscript id="aonoscrcss"><link media="all" href="https://www.jesuisundev.com/wp-content/cache/autoptimize/css/autoptimize_cf2b811069ad5527268492bc99155d00.css" rel="stylesheet" /></noscript><title>Comprendre WebAssembly en 5 minutes - Je suis un dev</title>
<!-- Speed of this site is optimised by WP Performance Score Booster plugin v1.9.2.2 - https://dipakgajjar.com/wp-performance-score-booster/ -->

<!-- This site is optimized with the Yoast SEO plugin v12.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="WebAssembly a rejoint le HTML, CSS et Javascript en tant que standard du web le 5 décembre 2019. Ça va être utile pour beaucoup de choses."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/" />
<meta property="og:locale" content="fr_FR" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Comprendre WebAssembly en 5 minutes" />
<meta property="og:description" content="WebAssembly a rejoint le HTML, CSS et Javascript en tant que standard du web le 5 décembre 2019. Ça va être utile pour beaucoup de choses." />
<meta property="og:url" content="https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/" />
<meta property="og:site_name" content="Je suis un dev" />
<meta property="article:tag" content="backend" />
<meta property="article:tag" content="développement" />
<meta property="article:tag" content="développeur" />
<meta property="article:tag" content="développeuse" />
<meta property="article:tag" content="internet" />
<meta property="article:tag" content="javascript" />
<meta property="article:tag" content="webassembly" />
<meta property="article:section" content="backend" />
<meta property="article:published_time" content="2020-02-03T05:06:52+00:00" />
<meta property="article:modified_time" content="2020-02-03T05:06:55+00:00" />
<meta property="og:updated_time" content="2020-02-03T05:06:55+00:00" />
<meta property="og:image" content="https://www.jesuisundev.com/wp-content/uploads/2020/02/GKyX0vw.jpg" />
<meta property="og:image:secure_url" content="https://www.jesuisundev.com/wp-content/uploads/2020/02/GKyX0vw.jpg" />
<meta property="og:image:width" content="634" />
<meta property="og:image:height" content="396" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="WebAssembly a rejoint le HTML, CSS et Javascript en tant que standard du web le 5 décembre 2019. Ça va être utile pour beaucoup de choses." />
<meta name="twitter:title" content="Comprendre WebAssembly en 5 minutes" />
<meta name="twitter:image" content="https://www.jesuisundev.com/wp-content/uploads/2020/02/GKyX0vw.jpg" />
<meta name="twitter:creator" content="@jesuisundev" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.jesuisundev.com/#website","url":"https://www.jesuisundev.com/","name":"Je suis un dev","description":"Je te donne plein de conseils utiles pour faire du dev. Y&#039;a des gifs marrants aussi.","potentialAction":{"@type":"SearchAction","target":"https://www.jesuisundev.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/#primaryimage","url":"https://i.imgur.com/GKyX0vw.jpg","caption":"Comprendre le WebAssembly en 5 minutes"},{"@type":"WebPage","@id":"https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/#webpage","url":"https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/","inLanguage":"fr-FR","name":"Comprendre WebAssembly en 5 minutes - Je suis un dev","isPartOf":{"@id":"https://www.jesuisundev.com/#website"},"primaryImageOfPage":{"@id":"https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/#primaryimage"},"datePublished":"2020-02-03T05:06:52+00:00","dateModified":"2020-02-03T05:06:55+00:00","author":{"@id":"https://www.jesuisundev.com/#/schema/person/d07b4e39118f22f8c6651208393950f4"},"description":"WebAssembly a rejoint le HTML, CSS et Javascript en tant que standard du web le 5 d\u00e9cembre 2019. \u00c7a va \u00eatre utile pour beaucoup de choses."},{"@type":["Person"],"@id":"https://www.jesuisundev.com/#/schema/person/d07b4e39118f22f8c6651208393950f4","name":"jesuisundev","image":{"@type":"ImageObject","@id":"https://www.jesuisundev.com/#authorlogo","url":"https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=96&d=mm&r=g","caption":"jesuisundev"},"description":"a","sameAs":["https://twitter.com/jesuisundev"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' />
<link href='https://ajax.googleapis.com' rel='preconnect' />
<link href='https://fonts.googleapis.com' rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Je suis un dev &raquo; Flux" href="https://www.jesuisundev.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Je suis un dev &raquo; Flux des commentaires" href="https://www.jesuisundev.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Je suis un dev &raquo; Comprendre WebAssembly en 5 minutes Flux des commentaires" href="https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/feed/" />












<script type='text/javascript' src='https://www.jesuisundev.com/wp-includes/js/jquery/jquery.js'></script>

<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.jesuisundev.com/wp-content/themes/nimbo/js/html5shiv.min.js'></script>
<![endif]-->
<!--[if lt IE 9]>
<script type='text/javascript' src='https://www.jesuisundev.com/wp-content/themes/nimbo/js/respond.min.js'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://www.jesuisundev.com/wp-json/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.jesuisundev.com/?p=5789' />
<link rel="alternate" type="application/json+oembed" href="https://www.jesuisundev.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.jesuisundev.com%2Fcomprendre-webassembly-en-5-minutes%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.jesuisundev.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.jesuisundev.com%2Fcomprendre-webassembly-en-5-minutes%2F&#038;format=xml" />
<link rel="icon" href="https://jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" sizes="32x32" />
<link rel="icon" href="https://jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" />
<meta name="msapplication-TileImage" content="https://jesuisundev.com/wp-content/uploads/2018/12/favicon-32x32-1.png" />
		
			<!-- Global site tag (gtag.js) - Google Analytics -->
	<script async src="https://www.googletagmanager.com/gtag/js?id=UA-55526551-1"></script>
	<script>  window.dataLayer = window.dataLayer || [];  function gtag(){dataLayer.push(arguments);}  gtag('js', new Date());  gtag('config', 'UA-55526551-1');</script>
	<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<script data-cfasync="false" id="ao_optimized_gfonts_webfontloader">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head>

<body data-rsssl=1 class="post-template-default single single-post postid-5789 single-format-standard wp-custom-logo wp-embed-responsive">


<!-- header (type 2) -->
<header id="bwp-header" class="bwp-header-two-rows">

	<!-- row 1 - logo container -->
	<div class="bwp-header-logo-row">
		<div class="container">
			<div class="bwp-header-logo-row-container clearfix">

				
					<!-- logo (image) -->
					<div id="bwp-custom-logo" class="bwp-logo-container bwp-logo-image-container"
						 data-logo-url="https://www.jesuisundev.com/wp-content/uploads/2019/07/cropped-cropped-jesuisundev_logo_black.png"
						 data-dark-logo-url="https://www.jesuisundev.com/wp-content/uploads/2019/07/cropped-jesuisundev_logo_white-1.png"
						 data-logo-alt="Je suis un dev">

						<a href="https://www.jesuisundev.com/" class="custom-logo-link" rel="home"><img width="200" height="113" src="https://www.jesuisundev.com/wp-content/uploads/2019/07/cropped-cropped-jesuisundev_logo_black.png" class="custom-logo" alt="Je suis un dev" /></a>
					</div>
					<!-- end: logo -->

									<br><br>
				<span>Je te donne plein de conseils utiles pour faire du dev. Y'a des gifs marrants aussi.</span>
				<br><br>
<!-- twitter -->
<a style="padding: 10px 8px;" href="https://twitter.com/jesuisundev" target="_blank" rel="noopener">
    <i class="fab fa-twitter"></i>
</a>
<!-- newsletter -->
<a style="padding: 10px 8px;" href="https://mailchi.mp/024d0ebb03ba/jesuisundev" rel="noopener" target="_blank">
    <i class="far fa-envelope"></i>
</a>
<!-- rss -->
<a style="padding: 10px 8px;" href="https://www.jesuisundev.com/feed/" target="_blank" rel="noopener">
    <i class="fas fa-rss-square"></i>
</a>
<!-- mail-->
<a style="padding: 10px 8px;" href="mailto:admin@jesuisundev.com" rel="noopener">
    <i class="fas fa-pen"></i>
</a>
			</div>
		</div>
	</div>
	<!-- end: row 1 - logo container -->

	<!-- row 2 - navigation container -->
	<div class="bwp-header-nav-row">
		<div class="container">
			<div class="bwp-header-nav-row-container clearfix">

				
			<!-- color switch -->
			<a href="#" rel="nofollow" id="bwp-color-switch" class="bwp-color-switch-icon">
									<i class="far fa-moon"></i>
								</a>
			<!-- end: color switch -->

			
			</div>
		</div>
	</div>
	<!-- end: row 2 - navigation container -->

</header>
<!-- end: header -->

	<!-- single blog post -->
	<section id="bwp-single-post">
		<div class="container">

			
			<!-- single post container -->
			<div class="bwp-single-post-container bwp-full-width-layout" role="main">

				<!-- single post -->
				<article id="bwp-post-5789" class="post-5789 post type-post status-publish format-standard has-post-thumbnail hentry category-backend category-developpement category-developpeur category-developpeuse category-internet category-javascript category-webassembly tag-backend tag-developpement tag-developpeur tag-developpeuse tag-internet tag-javascript tag-webassembly bwp-single-post-article">

					
		<!-- featured image -->
		<figure class="bwp-post-media">
			<noscript><img width="1000" src="https://i.imgur.com/GKyX0vw.jpg" class="attachment-nimbo-1200x500-crop size-nimbo-1200x500-crop wp-post-image" alt="Comprendre le WebAssembly en 5 minutes" /></noscript><img width="1000" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%201000%20%22%3E%3C/svg%3E' data-src="https://i.imgur.com/GKyX0vw.jpg" class="lazyload attachment-nimbo-1200x500-crop size-nimbo-1200x500-crop wp-post-image" alt="Comprendre le WebAssembly en 5 minutes" />		</figure>
		<!-- end: featured image -->

		
					<!-- content -->
					<div class="bwp-post-content">
								<p class="disclaimer">
			En dehors du titre, le générique masculin est utilisé sans aucune discrimination et uniquement dans le but d'alléger le texte.
		</p>
		<!-- metadata -->
		<ul class="bwp-single-post-metadata list-unstyled">

			
				<!-- date (with link) -->
				<li class="bwp-single-post-meta-date">
					<span>Posted on</span>
					<a href="https://www.jesuisundev.com/2020/02/03/">
						<span class="date updated">3 février 2020</span>
					</a>
				</li>
				<!-- end: date -->

				
			<!-- author -->
			<li class="bwp-single-post-meta-author">
				<span>By</span>
				<a href="https://www.jesuisundev.com/author/vooodoo/" title="Posts by jesuisundev" rel="author">
					<span class="vcard author">
						<span class="fn">jesuisundev</span>
					</span>
				</a>
			</li>
			<!-- end: author -->

			
					<!-- categories -->
					<li class="bwp-single-post-meta-categories">
						<span>In</span>
						<a href="https://www.jesuisundev.com/category/backend/" rel="category tag">backend</a>, <a href="https://www.jesuisundev.com/category/developpement/" rel="category tag">développement</a>, <a href="https://www.jesuisundev.com/category/developpeur/" rel="category tag">développeur</a>, <a href="https://www.jesuisundev.com/category/developpeuse/" rel="category tag">développeuse</a>, <a href="https://www.jesuisundev.com/category/internet/" rel="category tag">internet</a>, <a href="https://www.jesuisundev.com/category/javascript/" rel="category tag">javascript</a>, <a href="https://www.jesuisundev.com/category/webassembly/" rel="category tag">webassembly</a>					</li>
					<!-- end: categories -->

					
		</ul>
		<!-- end: metadata -->

		
			<!-- title -->
			<h1 class="bwp-post-title entry-title">Comprendre WebAssembly en 5 minutes</h1>
			<!-- end: title -->

			
		<!-- full post content -->
		<div class="bwp-content entry-content clearfix">

			
<!-- Horizontal Top Article -->
<ins class="adsbygoogle" style="display:block;margin:0 auto 30px auto" data-ad-client="ca-pub-5631435152140968" data-ad-slot="9970516334" data-ad-format="horizontal" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>



<p>WebAssembly a rejoint le HTML, CSS et Javascript en tant que standard du web le 5 décembre 2019. Ça va être utile pour beaucoup de choses et au niveau performances, c&#8217;est du jamais vu dans un navigateur. Si t&#8217;as cinq minutes devant toi, il faut que je t&#8217;explique la petite révolution en cours.</p>



<br><br>



<h3>Il était une fois</h3>



<p>En 1995, Javascript était créé <a rel="noreferrer noopener" aria-label="en l'espace de 10 jours (s’ouvre dans un nouvel onglet)" href="https://thenewstack.io/brendan-eich-on-creating-javascript-in-10-days-and-what-hed-do-differently-today/" target="_blank">en l&#8217;espace de 10 jours</a> par <a rel="noreferrer noopener" aria-label="Brendan Eich (s’ouvre dans un nouvel onglet)" href="https://twitter.com/BrendanEich" target="_blank">Brendan Eich</a>. Et à ce moment précis, Javascript c&#8217;était pas du tout désigné pour être rapide. <strong>Sortie de la  validation de formulaires c&#8217;est l&#8217;enfer comme c&#8217;est lent.</strong> Au fur et à mesure du temps ça s’arrangeait, mais à cette époque, Javascript jouait avec son caca côté performance.</p>



<p>En 2008, Google est sorti de nulle part et a posé sur la table son nouveau navigateur : Google Chrome. À l&#8217;intérieur de Chrome se trouvait un moteur Javascript appelé V8. <strong>Et la révolution de V8 c&#8217;était la compilation <a rel="noreferrer noopener" aria-label="Just in Time (s’ouvre dans un nouvel onglet)" href="https://fr.wikipedia.org/wiki/Compilation_%C3%A0_la_vol%C3%A9e" target="_blank">Just in Time</a> (JIT) du Javascript</strong>. Ce changement de code interprété à la compilation JIT accélérait monstrueusement les performances de Javascript, et donc des navigateurs de façon générale. Cette vitesse allait permettre la naissance de technologie comme NodeJS ou Électron et<a href="https://www.jesuisundev.com/pourquoi-javascript-est-il-si-populaire/" target="_blank" rel="noreferrer noopener" aria-label=" l'explosion de popularité (s’ouvre dans un nouvel onglet)"> l&#8217;explosion de popularité</a> de Javascript.</p>



<br><br>



<figure class="wp-block-image size-large size-full aligncenter"><noscript><img src="https://i.imgur.com/YHJMavH.jpg" alt="bolt"/></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://i.imgur.com/YHJMavH.jpg" alt="bolt"/></figure>



<br><br>



<p>En 2015, WebAssembly est pour la première fois annoncé avec <a rel="noreferrer noopener" aria-label="une petite démo d'un jeu (s’ouvre dans un nouvel onglet)" href="https://www.eteknix.com/gaming-in-your-browser-is-about-to-get-interesting-with-webassembly/" target="_blank">une petite démo d&#8217;un jeu</a> qui tourne sous Unity. Le jeu tourne directement dans le navigateur ! </p>



<p>En 2019, la W3C faisait de WebAssembly une nouvelle norme du web. Comme l&#8217;a été le moteur V8 à son époque, <strong>WebAssembly s&#8217;annonce comme la nouvelle révolution coté performance</strong>. WebAssembly est donc déjà là, et son top départ a été fulgurant.</p>



<br><br>



<figure class="wp-block-image size-large size-full aligncenter"><noscript><img src="https://cdn.theatlantic.com/assets/media/img/mt/2017/05/AP_501898297044/lead_720_405.jpg" alt="fast"/></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://cdn.theatlantic.com/assets/media/img/mt/2017/05/AP_501898297044/lead_720_405.jpg" alt="fast"/></figure>



<br><br>



<h3>C&#8217;est quoi WebAssembly ?</h3>



<p>WebAssembly, abrégé en wasm, est une façon d&#8217;utiliser du code qui n&#8217;est pas du Javascript et de le faire tourner dans ton navigateur. Ce code peut être par exemple du C, C++, Rust et plein d&#8217;autres. <strong>I</strong>l<strong> sera compilé et tournera dans ton navigateur à une vitesse quasi native sur ton CPU</strong>. Ce code est sous forme de fichier binaire que tu peux utiliser directement depuis Javascript comme un module.</p>



<p>Car oui, <strong>WebAssembly n&#8217;est pas là pour remplacer Javascript</strong>. Au contraire, ces deux technologies sont faites pour travailler ensemble. En utilisant <a rel="noreferrer noopener" aria-label="l'API Javascript (s’ouvre dans un nouvel onglet)" href="https://developer.mozilla.org/fr/docs/WebAssembly/Using_the_JavaScript_API" target="_blank">l&#8217;API Javascript</a> tu peux loader des modules WebAssembly dans ta page. Ce qui veut dire que tu peux profiter des performances de code compilé via WebAssembly avec la flexibilité de Javascript. C&#8217;est internet qui va être content.</p>



<br><br>



<figure class="wp-block-image size-large size-full aligncenter"><noscript><img src="https://i.imgur.com/gbBMTTf.jpg" alt="webassembly"/></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://i.imgur.com/gbBMTTf.jpg" alt="webassembly"/></figure>



<br><br>



<p>Le nom WebAssembly est un peu trompeur. <strong>Le WebAssembly fonctionne en effet pour le Web mais il n&#8217;y est pas limité !</strong> L&#8217;équipe qui a fait WebAssembly s&#8217;est bien fait chier à le faire de façon générique pour qu&#8217;il soit utilisé partout. On commence à en voir des <a rel="noreferrer noopener" aria-label="exemples (s’ouvre dans un nouvel onglet)" href="https://github.com/wasmerio/wasmer" target="_blank">exemples</a>.</p>



<p>Ensuite, il y a une idée fausse qui revient tout le temps. <strong>WebAssembly n&#8217;est pas un langage de programmation.</strong> WebAssembly est un format intermédiaire, un <a rel="noreferrer noopener" aria-label="bytecode (s’ouvre dans un nouvel onglet)" href="https://fr.wikipedia.org/wiki/Bytecode" target="_blank">bytecode</a>, qui agit comme une cible de compilation pour d&#8217;autres langages. OK, c&#8217;est pas clair faisons des dessins.</p>



<br><br>



<h3>Comment ça marche ?</h3>



<figure class="wp-block-image size-large size-full aligncenter"><noscript><img src="https://i.imgur.com/EHwFHv0.jpg" alt="webassembly"/></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://i.imgur.com/EHwFHv0.jpg" alt="webassembly"/></figure>



<br><br>



<p>T&#8217;as vu ça ? Encore une oeuvre d&#8217;art ce que je te propose comme schéma aujourd&#8217;hui. Tu me crois si je te dit que j&#8217;utilise Photoshop ?</p>



<p>Étape 1 : c&#8217;est toi et tes skills de développeurs. <strong>Tu produis du code source en C, C++</strong> (y&#8217;en a d&#8217;autres). Ce code-là est censé régler un problème ou faire un process trop intensif pour Javascript dans le navigateur.</p>



<p>Étape 2 : tu vas utiliser <a rel="noreferrer noopener" aria-label="Emscripten (s’ouvre dans un nouvel onglet)" href="https://emscripten.org/index.html" target="_blank">Emscripten</a> pour faire la traduction. <strong>Emscripten est une chaîne d&#8217;outil, construit avec <a rel="noreferrer noopener" aria-label="LLVM (s’ouvre dans un nouvel onglet)" href="https://fr.wikipedia.org/wiki/LLVM" target="_blank">LLVM</a>, qui va compiler ton code source en WebAssembly</strong>. Tu peux l&#8217;installer et compiler ce que tu veux en <a rel="noreferrer noopener" aria-label="quelques étapes rapide (s’ouvre dans un nouvel onglet)" href="https://webassembly.org/getting-started/developers-guide/" target="_blank">quelques étapes rapide</a>, on va regarder ça juste après. À la fin de cette étape, tu auras un fichier WASM.</p>



<p>Étape 3 : tu vas utiliser le fichier WASM dans ta page web. Si tu viens du futur, tu peux loader ce fichier comme n&#8217;importe quels modules ES6 dans ta page. À l&#8217;heure où j&#8217;écris ces lignes, l&#8217;utilisation est légèrement plus complexe, mais rien de fifou.</p>



<p>Allez, on met les mains dedans.</p>



<br><br>



<h3>Fais voir le code</h3>



<p>Tout d&#8217;abord, il nous faut un petit bout de code en C++ à compiler. Là où certains vont te proposer <a rel="noreferrer noopener" aria-label="Diablo 1 entier (s’ouvre dans un nouvel onglet)" href="https://d07riv.github.io/diabloweb/" target="_blank">Diablo 1 entier</a> comme exemple, moi je vais rester dans la simplicité avec une fonction qui additionne deux chiffres. On va pas prouver la vitesse de C++ avec ça, c&#8217;est pour l&#8217;exemple.</p>



<br><br>



<pre class="EnlighterJSRAW" data-enlighter-language="cpp" data-enlighter-theme="" data-enlighter-highlight="" data-enlighter-linenumbers="" data-enlighter-lineoffset="" data-enlighter-title="" data-enlighter-group="">int add(int firstNumber, int secondNumber) {
  return firstNumber + secondNumber;
}</pre>



<br><br>



<p>Ensuite direction la distribution Linux de ton choix. On va commencer par télécharger et installer emscripten.</p>



<br><br>



<pre class="EnlighterJSRAW" data-enlighter-language="shell" data-enlighter-theme="" data-enlighter-highlight="" data-enlighter-linenumbers="" data-enlighter-lineoffset="" data-enlighter-title="" data-enlighter-group=""># on installe les dépendances python et git
sudo apt-get install python2.7 git

# on va chercher emscripten via un git clone
git clone https://github.com/emscripten-core/emsdk.git

# on s'installe dans le dossier cloné
cd emsdk

# on télécharge (c'est gros) et on installe le SDK
./emsdk install latest

# on active le SDK
./emsdk activate latest

# on ajoute les variables d’environnement et on met à jour le PATH pour le terminal actuel
source ./emsdk_env.sh

# on vérifie que l'installation s'est bien passée
emcc --version

# on compile notre fichier C en template WebAssembly
emcc helloWebassembly.cpp -s WASM=1 -o helloWebassembly.html

# on sert le HTML et on regarde le résultat
emrun helloWebassembly.html</pre>



<br><br>



<p>C’était la manière hackerman de faire le wasm. Y&#8217;a plus simple que ça. Tu peux aller sur ce <a rel="noreferrer noopener" aria-label="site (s’ouvre dans un nouvel onglet)" href="https://mbebenita.github.io/WasmExplorer/" target="_blank">site</a> et <strong>mettre ton code C++ sur la gauche. Ensuite tu récupères le nom de la fonction exportée dans la partie WAT. Chez moi c&#8217;est &#8220;_Z3addii&#8221;.</strong> Tu n&#8217;as plus qu&#8217;à cliquer sur download et tu vas récupérer ton fichier wasm.  </p>



<p>Dernière étape, on va le faire tourner dans une page web.</p>



<br><br>



<pre class="EnlighterJSRAW" data-enlighter-language="js" data-enlighter-theme="" data-enlighter-highlight="" data-enlighter-linenumbers="" data-enlighter-lineoffset="" data-enlighter-title="" data-enlighter-group="">&lt;html>
  &lt;head>
    &lt;title>WASM test&lt;/title>
    &lt;link rel="stylesheet" href="/stylesheets/style.css" />
  &lt;/head>

  &lt;body>
    &lt;script>
      const getRandomNumber = () => Math.floor(Math.random() * 10000);

      WebAssembly.instantiateStreaming(
        fetch("https://012q1.sse.codesandbox.io/wasm/add.wasm")
      )
        .then(obj => obj.instance.exports._Z3addii)
        .then(add => {
          document.getElementById("addTarget").textContent = add(
            getRandomNumber(),
            getRandomNumber()
          );
        });
    &lt;/script>

    &lt;h1>Résultat du C++&lt;/h1>
    &lt;p id="addTarget">&lt;/p>
  &lt;/body>
&lt;/html></pre>



<br><br>



<p>Et voici la page web qui permet d&#8217;utiliser le C++ compilé en WebAssembly ! Je passe sur tout le HTML et les trucs évidents pour aller directement à la ligne 11 avec la fonction <strong>InstantiateStreaming</strong>. Comme le raconte <a rel="noreferrer noopener" aria-label="la documentation mozilla (s’ouvre dans un nouvel onglet)" href="https://developer.mozilla.org/fr/docs/Web/JavaScript/Reference/Objets_globaux/WebAssembly/instantiateStreaming" target="_blank">la documentation </a><a href="https://developer.mozilla.org/fr/docs/Web/JavaScript/Reference/Objets_globaux/WebAssembly/instantiateStreaming" target="_blank" rel="noreferrer noopener" aria-label="la documentation mozilla (s’ouvre dans un nouvel onglet)">M</a><a rel="noreferrer noopener" aria-label="la documentation mozilla (s’ouvre dans un nouvel onglet)" href="https://developer.mozilla.org/fr/docs/Web/JavaScript/Reference/Objets_globaux/WebAssembly/instantiateStreaming" target="_blank">ozilla</a>, cette fonction permet de <strong>compiler et d&#8217;instancier notre module WebAssembly via un simple fetch</strong>.</p>



<p>Ensuite, je récupère la fonction add via le nom qu&#8217;on a récupéré auparavant et je l&#8217;utilise pour remplacer un bout de DOM. Et TADA ! <strong>Du C++ via du Javascript dans ton internet.</strong> C&#8217;est pas fou ça ? Tiens regarde, je t&#8217;ai même fait <a rel="noreferrer noopener" aria-label="une codesandbox (s’ouvre dans un nouvel onglet)" href="https://codesandbox.io/s/webassembly-en-5-minutes-012q1?fontsize=14&amp;hidenavigation=1&amp;module=%2Fpublic%2Findex.html&amp;theme=dark" target="_blank">une codesandbox</a> avec une démo fonctionnelle.</p>



<br><br>



<iframe src="https://codesandbox.io/embed/webassembly-en-5-minutes-012q1?fontsize=14&amp;hidenavigation=1&amp;module=%2Fpublic%2Findex.html&amp;theme=dark" style="width:100%; height:500px; border:0; border-radius: 4px; overflow:hidden;" title="webassembly-en-5-minutes" allow="geolocation; microphone; camera; midi; vr; accelerometer; gyroscope; payment; ambient-light-sensor; encrypted-media; usb" sandbox="allow-modals allow-forms allow-popups allow-scripts allow-same-origin"></iframe>



<br><br>



<p>Tu vas me dire que c&#8217;est complexe juste pour faire ça, et t&#8217;as raison. <strong>Ils sont entrain de bosser pour remplacer le bout de Javascript d&#8217;instanciation par un simple import dans le futur.</strong> Donc patience ça va venir. On est trop dans le futur pour le moment.</p>



<br><br>



<figure class="wp-block-image size-large size-full aligncenter"><noscript><img src="https://i.imgur.com/4FjTgL7.jpg" alt="webassembly"/></noscript><img class="lazyload" src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20%20%22%3E%3C/svg%3E' data-src="https://i.imgur.com/4FjTgL7.jpg" alt="webassembly"/></figure>



<br><br>



<br><br>



<h3>Épilogue</h3>



<p>Ça fait déjà cinq minutes qu&#8217;on discute donc je m&#8217;arrête là. Tu veux faire pareil avec du Rust ? Je te conseille <a rel="noreferrer noopener" aria-label="cet excellent article (s’ouvre dans un nouvel onglet)" href="https://vincent-g.fr/rust-webassembly-wasm-everywhere/" target="_blank">cet excellent article</a>. Tu veux tout savoir sur WebAssembly et tu as du temps devant toi ? Je te conseille <a rel="noreferrer noopener" aria-label="cet excellent article (s’ouvre dans un nouvel onglet)" href="https://www.javascriptjanuary.com/blog/webassembly-neither-web-nor-assembly-but-revolutionary" target="_blank">cet excellent article</a>. Pour la suite de l&#8217;histoire, j&#8217;attends avec impatience ce que va nous amener cette ouverture du web sur d&#8217;autres langages. Y&#8217;a beaucoup de potentiel et on n&#8217;est pas au bout de nos surprises.</p>

			<!-- clearfix -->
			<div class="clearfix"></div>

			
		</div>
		<!-- end: full post content -->

		
			<!-- tags -->
			<div class="bwp-single-post-tags">
				Tags:<a href="https://www.jesuisundev.com/tag/backend/" rel="tag">backend</a>, <a href="https://www.jesuisundev.com/tag/developpement/" rel="tag">développement</a>, <a href="https://www.jesuisundev.com/tag/developpeur/" rel="tag">développeur</a>, <a href="https://www.jesuisundev.com/tag/developpeuse/" rel="tag">développeuse</a>, <a href="https://www.jesuisundev.com/tag/internet/" rel="tag">internet</a>, <a href="https://www.jesuisundev.com/tag/javascript/" rel="tag">javascript</a>, <a href="https://www.jesuisundev.com/tag/webassembly/" rel="tag">webassembly</a>			</div>
			<!-- end: tags -->

			
									<!-- share icons and counters -->
									<div class="clearfix">

										
	<!-- share -->
	<div class="bwp-single-post-share">
		<span>Share</span>
		<ul class="bwp-single-post-share-list list-unstyled">
			<!-- twitter -->
			<li>
				<a href="https://twitter.com/share?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&text=Comprendre WebAssembly en 5 minutes" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&text=Comprendre WebAssembly en 5 minutes', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
					<i class="fab fa-twitter"></i>
				</a>
			</li>
			<!-- end: twitter -->
			<!-- facebook -->
			<li>
				<a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&t=Comprendre%20WebAssembly%20en%205%20minutes" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&t=Comprendre%20WebAssembly%20en%205%20minutes', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
					<i class="fab fa-facebook-f"></i>
				</a>
			</li>
			<!-- end: facebook -->
			<!-- linkedin -->
			<li>
				<a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/" rel="nofollow noopener" target="_blank" class="bwp-linkedin-share" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&media=true', 'Linkedin', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
					<i class="fab fa-linkedin"></i>
				</a>
			</li>
			<!-- end: linkedin -->
			<!-- reddit -->
			<li>
				<a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&title=Comprendre%20WebAssembly%20en%205%20minutes" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&title=Comprendre%20WebAssembly%20en%205%20minutes', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
					<i class="fab fa-reddit-alien"></i>
				</a>
			</li>
			<!-- end: reddit -->
			<!-- pinterest -->
			<li>
				<a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&media=https://i.imgur.com/GKyX0vw.jpg&description=Comprendre%20WebAssembly%20en%205%20minutes" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/&media=https://i.imgur.com/GKyX0vw.jpg&description=Comprendre%20WebAssembly%20en%205%20minutes', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
					<i class="fab fa-pinterest-p"></i>
				</a>
			</li>
			<!-- end: pinterest -->
			<!-- vk -->
			<li>
				<a href="https://vk.com/share.php?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
					<i class="fab fa-vk"></i>
				</a>
			</li>
			<!-- end: vk -->
		</ul>
	</div>
	<!-- end: share -->

	
									</div>
									<!-- end: share icons and counters -->

									
	<nav class="navigation post-navigation" role="navigation" aria-label="Publications">
		<h2 class="screen-reader-text">Navigation de l’article</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.jesuisundev.com/comment-considerees-developpeurs-france/" rel="prev"><span class="meta-nav"><i class="fas fa-caret-left"></i>Previous post</span><span class="post-title-nav">Comment sont considéré(e)s les développeur(euse)s en France ?</span></a></div></div>
	</nav>
					</div>
					<!-- end: content -->

				</article>
				<!-- end: single post -->

				
			<!-- about the author -->
			<h2 class="bwp-container-title">Qui me parle ?</h2>
			<div class="bwp-about-author clearfix">
				
					<!-- avatar -->

					<figure class="bwp-about-author-avatar">

						<a href="https://www.twitter.com/jesuisundev" title="Posts by jesuisundev">

							<noscript><img alt='jesuisundev' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=288&#038;d=mm&#038;r=g 2x' class='avatar avatar-144 photo' height='144' width='144' /></noscript><img alt='jesuisundev' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%20144%20144%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=288&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-144 photo' height='144' width='144' />
							<div class="bwp-avatar-bg-overlay"></div>

						</a>

					</figure>

					<!-- end: avatar -->

								<!-- biographical info -->
				<div class="bwp-about-author-bio-wrap">
					
						<div class="bwp-about-author-bio">Je suis un dev. 
En ce moment je suis Backend Développeur / DevOps à <a href="https://montreal.ubisoft.com/" target="_blank">Ubisoft</a>. 
Je suis passionné du dev et j'écris comme je parle. 
Je continue à te parler quotidiennement sur mon <a href="https://www.twitter.com/jesuisundev/" target="_blank">Twitter</a>. 
Tu peux m'insulter à cette <a href="mailto:admin@jesuisundev.com">e-mail</a> ou le faire directement dans les commentaires juste en dessous. Y'a même une <a href="https://mailchi.mp/024d0ebb03ba/jesuisundev" target="_blank">newsletter</a> !</div>
									</div>
				<!-- end: biographical info -->
			</div>
			<!-- end: about the author -->

			
<!-- comments -->
<div id="comments" class="comments-area">

	
		<!-- comments title -->
		<h2 class="comments-title">
			Commentaire(s)		</h2>
		<!-- end: comments title -->

		<!-- comment list and navigation -->
		<div class="comment-list-wrap">

			<ol class="comment-list">
						<li id="comment-3647" class="comment even thread-even depth-1">
			<article id="div-comment-3647" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<noscript><img alt='' src='https://secure.gravatar.com/avatar/ced8fb240716f3666170caaf3d71c017?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ced8fb240716f3666170caaf3d71c017?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ced8fb240716f3666170caaf3d71c017?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ced8fb240716f3666170caaf3d71c017?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' />						<b class="fn">Thibaut Decherit</b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/#comment-3647">
							<time datetime="2020-02-03T16:58:00+01:00">
								3 février 2020 à 16 h 58 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Pour nuancer : <a href="https://twitter.com/aral/status/1206173737730674688" rel="nofollow ugc">https://twitter.com/aral/status/1206173737730674688</a></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-3647' data-commentid="3647" data-postid="5789" data-belowelement="div-comment-3647" data-respondelement="respond" aria-label='Répondre à Thibaut Decherit'>Répondre</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
		<li id="comment-3648" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-3648" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<noscript><img alt='' src='https://secure.gravatar.com/avatar/45eb9f0a1ccf5b63536071ca0bc8a8ed?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/45eb9f0a1ccf5b63536071ca0bc8a8ed?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/45eb9f0a1ccf5b63536071ca0bc8a8ed?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/45eb9f0a1ccf5b63536071ca0bc8a8ed?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' />						<b class="fn"><a href='https://tetalab.org/' rel='external nofollow ugc' class='url'>tth</a></b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/#comment-3648">
							<time datetime="2020-02-03T16:59:07+01:00">
								3 février 2020 à 16 h 59 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Python 2.7, c&#8217;est pas un truc obsolète ?</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-3648' data-commentid="3648" data-postid="5789" data-belowelement="div-comment-3648" data-respondelement="respond" aria-label='Répondre à tth'>Répondre</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
		<li id="comment-3652" class="comment even thread-even depth-1">
			<article id="div-comment-3652" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<noscript><img alt='' src='https://secure.gravatar.com/avatar/231642f9618308672dc5f8c192ad232b?s=92&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/231642f9618308672dc5f8c192ad232b?s=184&#038;d=mm&#038;r=g 2x' class='avatar avatar-92 photo' height='92' width='92' /></noscript><img alt='' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2092%2092%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/231642f9618308672dc5f8c192ad232b?s=92&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/231642f9618308672dc5f8c192ad232b?s=184&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-92 photo' height='92' width='92' />						<b class="fn"><a href='https://apprendre-la-programmation.net' rel='external nofollow ugc' class='url'>Gaëtan</a></b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://www.jesuisundev.com/comprendre-webassembly-en-5-minutes/#comment-3652">
							<time datetime="2020-02-03T20:48:05+01:00">
								3 février 2020 à 20 h 48 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Bravo Mehdi ! Job accompli ! J&#8217;ai bien compris à quoi sert Web Assembly et j&#8217;ai déjà quelques idées d&#8217;utilisations.</p>
<p>Un grand merci à toi !</p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='#comment-3652' data-commentid="3652" data-postid="5789" data-belowelement="div-comment-3652" data-respondelement="respond" aria-label='Répondre à Gaëtan'>Répondre</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
			</ol>

			
		</div>
		<!-- end: comment list and navigation -->

		
	
		<div id="respond" class="comment-respond">
		<h2 id="reply-title" class="comment-reply-title"><span>T&#039;en penses quoi ?</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/comprendre-webassembly-en-5-minutes/#respond" style="display:none;">Annulé</a></small></h2><form action="https://www.jesuisundev.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published. Required fields are marked *</p><p class="comment-form-comment"><label for="comment">Commentaire</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Nom <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Adresse de messagerie <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" required='required' /></p>
<p class="comment-form-url"><label for="url">Site web</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Enregistrer mon nom, mon e-mail et mon site web dans le navigateur pour mon prochain commentaire.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post" /> <input type='hidden' name='comment_post_ID' value='5789' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="b454797e0a" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="226"/></p></form>	</div><!-- #respond -->
	
</div>
<!-- end: comments -->

			<!-- related posts (by tags) -->
			<div class="bwp-related-posts bwp-show-3-related-posts">
				<!-- title -->
				<h2 class="bwp-container-title">Et sinon</h2>
				<!-- end: title -->
				<!-- posts list -->
				<div class="bwp-related-posts-list clearfix">

					
<!-- post - standard format -->
<article id="bwp-post-3599" class="post-3599 post type-post status-publish format-standard has-post-thumbnail hentry category-backend category-developpement category-go tag-backend tag-developpement tag-go">
	<div class="bwp-post-wrap">

		
		
		<!-- content -->
		<div class="bwp-post-content">
			
		<!-- date -->
		<div class="bwp-post-date">
							<a href="https://www.jesuisundev.com/2019/12/16/">
					<span class="date updated">16 décembre 2019</span>
				</a>
					</div>
		<!-- end: date -->

		
			<!-- title -->
			<h3 class="bwp-post-title entry-title">
									<a href="https://www.jesuisundev.com/comprendre-go-en-5-minutes/">Comprendre Go en 5 minutes</a>
							</h3>
			<!-- end: title -->

			
			<!-- excerpt -->
			<div class="bwp-post-excerpt entry-content">
				<p>J&#8217;ai passé du temps avec Go pour m&#8217;amuser ces derniers mois. Je te propose une introduction au langage préféré de Google.</p>
			</div>
			<!-- end: excerpt -->

			
			<!-- author and icons -->
			<div class="clearfix">

				
		<!-- author -->
		<div class="bwp-post-author">
							<figure class="bwp-post-author-avatar">
					<a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev">
						<noscript><img alt='jesuisundev' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' /></noscript><img alt='jesuisundev' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2072%2072%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-72 photo' height='72' width='72' />						<div class="bwp-avatar-bg-overlay"></div>
					</a>
				</figure>
						<div class="bwp-post-author-name">
				<a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev" rel="author">
					<span class="vcard author">
						<span class="fn">jesuisundev</span>
					</span>
				</a>
			</div>
		</div>
		<!-- end: author -->

		
				<!-- icons -->
				<div class="bwp-post-icons bwp-no-post-author">

					
					
	<!-- share -->
	<div class="bwp-post-share">
		<a href="#" rel="nofollow" class="bwp-post-share-icon">
			<i class="fas fa-share-alt"></i>
		</a>
		<div class="bwp-post-share-list-wrap">
			<ul class="bwp-post-share-list list-unstyled clearfix">
				<!-- twitter -->
				<li>
					<a href="https://twitter.com/share?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&text=Comprendre Go en 5 minutes" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&text=Comprendre Go en 5 minutes', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
						<i class="fab fa-twitter"></i>
					</a>
				</li>
				<!-- end: twitter -->
				<!-- facebook -->
				<li>
					<a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&t=Comprendre%20Go%20en%205%20minutes" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&t=Comprendre%20Go%20en%205%20minutes', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
						<i class="fab fa-facebook-f"></i>
					</a>
				</li>
				<!-- end: facebook -->
				<!-- linkedin -->
				<li>
					<a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/" rel="nofollow noopener" target="_blank" class="bwp-linkedin-share" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&media=true', 'Linkedin', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-linkedin"></i>
					</a>
				</li>
				<!-- end: linkedin -->
				<!-- reddit -->
				<li>
					<a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&title=Comprendre%20Go%20en%205%20minutes" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&title=Comprendre%20Go%20en%205%20minutes', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-reddit-alien"></i>
					</a>
				</li>
				<!-- end: reddit -->
				<!-- pinterest -->
				<li>
					<a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&media=https://i.imgur.com/kEpxd3I.png&description=Comprendre%20Go%20en%205%20minutes" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/&media=https://i.imgur.com/kEpxd3I.png&description=Comprendre%20Go%20en%205%20minutes', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-pinterest-p"></i>
					</a>
				</li>
				<!-- end: pinterest -->
				<!-- vk -->
				<li>
					<a href="https://vk.com/share.php?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/comprendre-go-en-5-minutes/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-vk"></i>
					</a>
				</li>
				<!-- end: vk -->
			</ul>
		</div>
	</div>
	<!-- end: share -->

	
				</div>
				<!-- end: icons -->

				
			</div>
			<!-- end: author and icons -->

			
		</div>
		<!-- end: content -->

	</div>
</article>
<!-- end: post - standard format -->

<!-- post - standard format -->
<article id="bwp-post-2888" class="post-2888 post type-post status-publish format-standard has-post-thumbnail hentry category-developpement category-developpeur category-developpeuse tag-developpement tag-developpeur tag-developpeuse">
	<div class="bwp-post-wrap">

		
			<!-- sticky post - icon -->
			<div class="bwp-post-sticky-mark">
				<i class="fas fa-chart-line"></i>
			</div>
			<!-- end: sticky post - icon -->

			
		
		<!-- content -->
		<div class="bwp-post-content">
			
		<!-- date -->
		<div class="bwp-post-date">
							<a href="https://www.jesuisundev.com/2020/01/27/">
					<span class="date updated">27 janvier 2020</span>
				</a>
					</div>
		<!-- end: date -->

		
			<!-- title -->
			<h3 class="bwp-post-title entry-title">
									<a href="https://www.jesuisundev.com/comment-considerees-developpeurs-france/">Comment sont considéré(e)s les développeur(euse)s en France ?</a>
							</h3>
			<!-- end: title -->

			
			<!-- excerpt -->
			<div class="bwp-post-excerpt entry-content">
				<p>Beaucoup de monde s&#8217;accorde à dire que les développeurs en France sont considérés comme des subalternes bas de gamme. Un centre de coût méprisé.</p>
			</div>
			<!-- end: excerpt -->

			
			<!-- author and icons -->
			<div class="clearfix">

				
		<!-- author -->
		<div class="bwp-post-author">
							<figure class="bwp-post-author-avatar">
					<a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev">
						<noscript><img alt='jesuisundev' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' /></noscript><img alt='jesuisundev' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2072%2072%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-72 photo' height='72' width='72' />						<div class="bwp-avatar-bg-overlay"></div>
					</a>
				</figure>
						<div class="bwp-post-author-name">
				<a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev" rel="author">
					<span class="vcard author">
						<span class="fn">jesuisundev</span>
					</span>
				</a>
			</div>
		</div>
		<!-- end: author -->

		
				<!-- icons -->
				<div class="bwp-post-icons bwp-no-post-author">

					
					
	<!-- share -->
	<div class="bwp-post-share">
		<a href="#" rel="nofollow" class="bwp-post-share-icon">
			<i class="fas fa-share-alt"></i>
		</a>
		<div class="bwp-post-share-list-wrap">
			<ul class="bwp-post-share-list list-unstyled clearfix">
				<!-- twitter -->
				<li>
					<a href="https://twitter.com/share?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&text=Comment sont considéré(e)s les développeur(euse)s en France ?" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&text=Comment sont considéré(e)s les développeur(euse)s en France ?', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
						<i class="fab fa-twitter"></i>
					</a>
				</li>
				<!-- end: twitter -->
				<!-- facebook -->
				<li>
					<a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&t=Comment%20sont%20consid%C3%A9r%C3%A9%28e%29s%20les%20d%C3%A9veloppeur%28euse%29s%20en%20France%20%3F" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&t=Comment%20sont%20consid%C3%A9r%C3%A9%28e%29s%20les%20d%C3%A9veloppeur%28euse%29s%20en%20France%20%3F', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
						<i class="fab fa-facebook-f"></i>
					</a>
				</li>
				<!-- end: facebook -->
				<!-- linkedin -->
				<li>
					<a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/" rel="nofollow noopener" target="_blank" class="bwp-linkedin-share" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&media=true', 'Linkedin', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-linkedin"></i>
					</a>
				</li>
				<!-- end: linkedin -->
				<!-- reddit -->
				<li>
					<a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&title=Comment%20sont%20consid%C3%A9r%C3%A9%28e%29s%20les%20d%C3%A9veloppeur%28euse%29s%20en%20France%20%3F" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&title=Comment%20sont%20consid%C3%A9r%C3%A9%28e%29s%20les%20d%C3%A9veloppeur%28euse%29s%20en%20France%20%3F', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-reddit-alien"></i>
					</a>
				</li>
				<!-- end: reddit -->
				<!-- pinterest -->
				<li>
					<a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&media=https://i.imgur.com/UXlWZep.jpg&description=Comment%20sont%20consid%C3%A9r%C3%A9%28e%29s%20les%20d%C3%A9veloppeur%28euse%29s%20en%20France%20%3F" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/&media=https://i.imgur.com/UXlWZep.jpg&description=Comment%20sont%20consid%C3%A9r%C3%A9%28e%29s%20les%20d%C3%A9veloppeur%28euse%29s%20en%20France%20%3F', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-pinterest-p"></i>
					</a>
				</li>
				<!-- end: pinterest -->
				<!-- vk -->
				<li>
					<a href="https://vk.com/share.php?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/comment-considerees-developpeurs-france/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-vk"></i>
					</a>
				</li>
				<!-- end: vk -->
			</ul>
		</div>
	</div>
	<!-- end: share -->

	
				</div>
				<!-- end: icons -->

				
			</div>
			<!-- end: author and icons -->

			
		</div>
		<!-- end: content -->

	</div>
</article>
<!-- end: post - standard format -->

<!-- post - standard format -->
<article id="bwp-post-4058" class="post-4058 post type-post status-publish format-standard has-post-thumbnail hentry category-developpement category-developpeur category-developpeuse tag-developpement tag-developpeur tag-developpeuse">
	<div class="bwp-post-wrap">

		
			<!-- sticky post - icon -->
			<div class="bwp-post-sticky-mark">
				<i class="fas fa-chart-line"></i>
			</div>
			<!-- end: sticky post - icon -->

			
		
		<!-- content -->
		<div class="bwp-post-content">
			
		<!-- date -->
		<div class="bwp-post-date">
							<a href="https://www.jesuisundev.com/2019/10/21/">
					<span class="date updated">21 octobre 2019</span>
				</a>
					</div>
		<!-- end: date -->

		
			<!-- title -->
			<h3 class="bwp-post-title entry-title">
									<a href="https://www.jesuisundev.com/competences-clefs-pour-developpeurs/">Compétences clefs pour développeur(euse)s</a>
							</h3>
			<!-- end: title -->

			
			<!-- excerpt -->
			<div class="bwp-post-excerpt entry-content">
				<p>Les compétences clefs pour tous développeurs ne sont pas une liste sans fin de langages et de technologies. Je vois partout ces check lists interminables.</p>
			</div>
			<!-- end: excerpt -->

			
			<!-- author and icons -->
			<div class="clearfix">

				
		<!-- author -->
		<div class="bwp-post-author">
							<figure class="bwp-post-author-avatar">
					<a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev">
						<noscript><img alt='jesuisundev' src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='avatar avatar-72 photo' height='72' width='72' /></noscript><img alt='jesuisundev' src='data:image/svg+xml,%3Csvg%20xmlns=%22http://www.w3.org/2000/svg%22%20viewBox=%220%200%2072%2072%22%3E%3C/svg%3E' data-src='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=72&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/ec6889c543b03b45a9a37076791dbe30?s=144&#038;d=mm&#038;r=g 2x' class='lazyload avatar avatar-72 photo' height='72' width='72' />						<div class="bwp-avatar-bg-overlay"></div>
					</a>
				</figure>
						<div class="bwp-post-author-name">
				<a href="https://www.jesuisundev.com/author/vooodoo/" title="Posted by jesuisundev" rel="author">
					<span class="vcard author">
						<span class="fn">jesuisundev</span>
					</span>
				</a>
			</div>
		</div>
		<!-- end: author -->

		
				<!-- icons -->
				<div class="bwp-post-icons bwp-no-post-author">

					
					
	<!-- share -->
	<div class="bwp-post-share">
		<a href="#" rel="nofollow" class="bwp-post-share-icon">
			<i class="fas fa-share-alt"></i>
		</a>
		<div class="bwp-post-share-list-wrap">
			<ul class="bwp-post-share-list list-unstyled clearfix">
				<!-- twitter -->
				<li>
					<a href="https://twitter.com/share?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&text=Compétences clefs pour développeur(euse)s" rel="nofollow noopener" target="_blank" class="bwp-twitter-share" onclick="window.open('https://twitter.com/share?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&text=Compétences clefs pour développeur(euse)s', 'Twitter', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
						<i class="fab fa-twitter"></i>
					</a>
				</li>
				<!-- end: twitter -->
				<!-- facebook -->
				<li>
					<a href="https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&t=Comp%C3%A9tences%20clefs%20pour%20d%C3%A9veloppeur%28euse%29s" rel="nofollow noopener" target="_blank" class="bwp-facebook-share" onclick="window.open('https://www.facebook.com/sharer.php?u=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&t=Comp%C3%A9tences%20clefs%20pour%20d%C3%A9veloppeur%28euse%29s', 'Facebook', 'width=700,height=500,left='+(screen.availWidth/2-350)+',top='+(screen.availHeight/2-250)+''); return false;">
						<i class="fab fa-facebook-f"></i>
					</a>
				</li>
				<!-- end: facebook -->
				<!-- linkedin -->
				<li>
					<a href="https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/" rel="nofollow noopener" target="_blank" class="bwp-linkedin-share" onclick="window.open('https://www.linkedin.com/sharing/share-offsite/?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&media=true', 'Linkedin', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-linkedin"></i>
					</a>
				</li>
				<!-- end: linkedin -->
				<!-- reddit -->
				<li>
					<a href="https://www.reddit.com/submit?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&title=Comp%C3%A9tences%20clefs%20pour%20d%C3%A9veloppeur%28euse%29s" rel="nofollow noopener" target="_blank" class="bwp-reddit-share" onclick="window.open('https://www.reddit.com/submit?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&title=Comp%C3%A9tences%20clefs%20pour%20d%C3%A9veloppeur%28euse%29s', 'Reddit', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-reddit-alien"></i>
					</a>
				</li>
				<!-- end: reddit -->
				<!-- pinterest -->
				<li>
					<a href="http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&media=https://i.imgur.com/v45Grq5.jpg&description=Comp%C3%A9tences%20clefs%20pour%20d%C3%A9veloppeur%28euse%29s" rel="nofollow noopener" target="_blank" class="bwp-pinterest-share" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/&media=https://i.imgur.com/v45Grq5.jpg&description=Comp%C3%A9tences%20clefs%20pour%20d%C3%A9veloppeur%28euse%29s', 'Pinterest', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-pinterest-p"></i>
					</a>
				</li>
				<!-- end: pinterest -->
				<!-- vk -->
				<li>
					<a href="https://vk.com/share.php?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/" rel="nofollow noopener" target="_blank" class="bwp-vk-share" onclick="window.open('https://vk.com/share.php?url=https://www.jesuisundev.com/competences-clefs-pour-developpeurs/', 'VK', 'width=800,height=700,left='+(screen.availWidth/2-400)+',top='+(screen.availHeight/2-350)+''); return false;">
						<i class="fab fa-vk"></i>
					</a>
				</li>
				<!-- end: vk -->
			</ul>
		</div>
	</div>
	<!-- end: share -->

	
				</div>
				<!-- end: icons -->

				
			</div>
			<!-- end: author and icons -->

			
		</div>
		<!-- end: content -->

	</div>
</article>
<!-- end: post - standard format -->

				</div>
				<!-- end: posts list -->
			</div>
			<!-- end: related posts -->

			
				<!--<div class="newsletter">
          				<h2 id="newsletter-title" class="bwp-container-title">
            					<span>Pas mal. Je vais m'inscrire à la newsletter !</span>
          				</h2>

          				        			</div>-->

			</div>
			<!-- end: single post container -->

			
			
		</div>
	</section>
	<!-- end: single blog post -->

	
<!-- footer -->
<footer id="bwp-footer">
	<div class="container">
		<div class="bwp-footer-container clearfix">

			
				<!-- footer text -->
				<div class="bwp-footer-text">
					Copyright - Je suis un dev					- 2020 - <a style="text-decoration:none !important" href="https://www.jesuisundev.com/privacy-policy/" target="_blank" rel="noopener">Politique de confidentialité</a>
				</div>
				<!-- end: footer text -->

				
					<!-- social links -->
					<div class="bwp-footer-social-links clearfix">
						<!-- twitter -->
<a href="https://twitter.com/jesuisundev" target="_blank" rel="noopener">
    <i class="fab fa-twitter"></i>
</a>
<!-- newsletter -->
<a href="https://mailchi.mp/024d0ebb03ba/jesuisundev" rel="noopener" target="_blank">
    <i class="far fa-envelope"></i>
</a>
<!-- rss -->
<a href="https://www.jesuisundev.com/feed/" target="_blank" rel="noopener">
    <i class="fas fa-rss-square"></i>
</a>
<!-- mail-->
<a href="mailto:admin@jesuisundev.com" rel="noopener">
    <i class="fas fa-pen"></i>
</a>					</div>
					<!-- end: social links -->

					
		</div>
	</div>
</footer>
<!-- end: footer -->


<noscript><style>.lazyload{display:none;}</style></noscript><script data-noptimize="1">window.lazySizesConfig=window.lazySizesConfig||{};window.lazySizesConfig.loadMode=1;</script><script async data-noptimize="1" src='https://www.jesuisundev.com/wp-content/plugins/autoptimize/classes/external/js/lazysizes.min.js?ao_version=2.6.1'></script>

<script type='text/javascript'>
/* <![CDATA[ */
var nimboCookiesInformationData = {"cookiesInfoWindow":"hide","cookiesInfoOnMobile":"hidden-window"};
/* ]]> */
</script>

<script type='text/javascript'>
/* <![CDATA[ */
var nimboSocialMediaData = {"ajaxURL":"https:\/\/www.jesuisundev.com\/wp-admin\/admin-ajax.php","ajaxNonce":"1bc79a8494"};
/* ]]> */
</script>







<script type='text/javascript'>
/* <![CDATA[ */
var nimboData = {"isMobile":"false","isSingular":"true","isAdminBarShowing":"false","headerType":"header-two-rows","stickyHeader":"off","logoType":"image","menuType":"hidden-menu","colorSwitch":"on","darkColorSwitchIconType":"sun","dropdownSearch":"hide","masonryColumnWidth":".bwp-col-3-default","toTopButton":"show","colorSwitchCookies":"on"};
/* ]]> */
</script>


<script type='text/javascript' src='https://www.jesuisundev.com/wp-content/cache/autoptimize/js/autoptimize_single_8decb0ce7eb8097d463a77d859a02725.js'></script>
<script type='text/javascript' src='https://www.jesuisundev.com/wp-content/plugins/enlighter/resources/EnlighterJS.min.js'></script>

<script type='text/javascript'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"off","fifu_woo_lbox":"on","fifu_woo_zoom":"inline"};
/* ]]> */
</script>


<script type="text/javascript">/* <![CDATA[ */EnlighterJS_Config = {"selector":{"block":"pre.EnlighterJSRAW","inline":"code.EnlighterJSRAW"},"language":"js","theme":"atomic","indent":2,"hover":"hoverEnabled","showLinenumbers":true,"rawButton":true,"infoButton":true,"windowButton":true,"rawcodeDoubleclick":false,"grouping":true,"cryptex":{"enabled":false,"email":"mail@example.tld"}};!function(){var a=function(a){var b="Enlighter Error: ";console.error?console.error(b+a):console.log&&console.log(b+a)};return window.addEvent?"undefined"==typeof EnlighterJS?void a("Javascript Resources not loaded yet!"):"undefined"==typeof EnlighterJS_Config?void a("Configuration not loaded yet!"):void window.addEvent("domready",function(){EnlighterJS.Util.Init(EnlighterJS_Config.selector.block,EnlighterJS_Config.selector.inline,EnlighterJS_Config)}):void a("MooTools Framework not loaded yet!")}();;/* ]]> */</script><script defer src="https://www.jesuisundev.com/wp-content/cache/autoptimize/js/autoptimize_30092f5d6a749ce97adb265e14f2b16c.js"></script><script data-cfasync='false'>!function(t){"use strict";t.loadCSS||(t.loadCSS=function(){});var e=loadCSS.relpreload={};if(e.support=function(){var e;try{e=t.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),e.bindMediaToggle=function(t){function e(){t.media=a}var a=t.media||"all";t.addEventListener?t.addEventListener("load",e):t.attachEvent&&t.attachEvent("onload",e),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(e,3e3)},e.poly=function(){if(!e.support())for(var a=t.document.getElementsByTagName("link"),n=0;n<a.length;n++){var o=a[n];"preload"!==o.rel||"style"!==o.getAttribute("as")||o.getAttribute("data-loadcss")||(o.setAttribute("data-loadcss",!0),e.bindMediaToggle(o))}},!e.support()){e.poly();var a=t.setInterval(e.poly,500);t.addEventListener?t.addEventListener("load",function(){e.poly(),t.clearInterval(a)}):t.attachEvent&&t.attachEvent("onload",function(){e.poly(),t.clearInterval(a)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:t.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script></body>
</html>

<!-- Dynamic page generated in 0.527 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-02-03 20:48:27 -->

<!-- super cache -->